Bug 61820 - USB Sync with Visor Prism results in segfault
USB Sync with Visor Prism results in segfault
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: kernel (Show other bugs)
skipjack-beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
:
Depends On:
Blocks: 61590
  Show dependency treegraph
 
Reported: 2002-03-24 17:36 EST by Brian Salomaki
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-15 08:59:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages - there are a few instances of the segfault near the end (89.60 KB, text/plain)
2002-03-24 17:39 EST, Brian Salomaki
no flags Details

  None (edit)
Description Brian Salomaki 2002-03-24 17:36:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020314

Description of problem:
When using the pilot-link tools to access my USB Visor Prism, the tools complete
successfully, and then segfault on exit.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Press hotsync button on cradle to allow hotplug to load drivers, etc.
2. Run a pilot-link program (dlpsh or pilot-xfer I've tried so far)
3. Let program finish

Actual Results:  Program completes successfully, then segmentation faults on exit.

Expected Results:  Program should complete successfully, and exit cleanly.

Additional info:

I also tried with a version I had around of pilot-link 0.9.6 from cvs, that did
the same thing.  Also, there is a log message about an error loading the visor
module/driver.  It is shown loaded in an lsmod, however.

I'll attach /var/log/messages - let me know if there's anything else you need
Comment 1 Brian Salomaki 2002-03-24 17:39:13 EST
Created attachment 50024 [details]
/var/log/messages - there are a few instances of the segfault near the end
Comment 2 Ngo Than 2002-03-26 05:19:16 EST
Could you please try with kernel-2.4.9-21 if this bug is fixed? thanks
Comment 3 Brian Salomaki 2002-03-26 11:30:55 EST
Where can I get this from?  Do you mean 2.4.9-31 from 7.2 updates?  I can't find
a copy of 2.4.9-21 for i386/i686.  For what it's worth, this had been working in
7.2 before I upgraded to the beta, with 2.4.9-31.
Comment 4 Ngo Than 2002-03-27 06:49:18 EST
i think it should be a bug in kernel.
Comment 5 Brian Salomaki 2002-03-28 10:25:37 EST
Just wondering since I havne't heard anything yet - do you still need me to try
another kernel?  If so, where can I get it?
Comment 6 Pete Zaitcev 2002-03-28 11:22:00 EST
It would be useful if you installed the current Raw Hide kernel
from ftp.redhat.com /pub/redhat/linux/rawhide/i386/RedHat/RPMS.
It is far from production, but helps to see if it fixes the problem.
The maintainer (Greg K-H) told me that he fixed some similar
things around 2.4.12.
Comment 7 Pete Zaitcev 2002-03-28 11:23:17 EST
BTW, DO NOT REMOVE 2.4.9-31. If Raw Hide bombs on you,
you have to have a backup. Have them side by side in
/boot/grub/grub.conf.
Comment 8 Brian Salomaki 2002-03-28 16:07:02 EST
I tried the Rawhide kernel (2.4.18-0.10), and that produced the same segfault
error as the skipjack kernel that was installed by default (2.4.18-0.4).  I also
installed 2.4.9-31 from 7.2 updates, and with this kernel, there is no
segmentation fault.

I also tried (while running 2.4.18-0.10) to rebuild the pilot-link package from
SRPMS to see if that maybe helped, and that package produced the same error. 
Let me know what else you want me to try, or if there's any more information I
can give you.
Comment 9 Greg Kroah-Hartman 2002-03-28 16:27:56 EST
This is a known bug, sorry.
It's fixed in the 2.5 tree, and there's a quick fix at:
http://www.kernel.org/pub/linux/kernel/people/gregkh/usb/2.4/usb-visor_hack-2.4.18.patch

But that patch will break all other usb-serial drivers.  I'll make a patch that
will work for all devices in a short bit.
Comment 10 Greg Kroah-Hartman 2002-03-28 16:51:57 EST
Real fix for this bug is now at:
http://www.kernel.org/pub/linux/kernel/people/gregkh/usb/2.4/usb-serial_visor_fix-2.4.18.patch

Pete, feel free to add this to your kernel :)
Comment 11 Pete Zaitcev 2002-04-01 12:57:05 EST
It is too close for a release, and I do not have the hardware
even for a sanity test. I am casting about for help from
Meridian people. The fix looks good, but I have a history
of botching even trivial fixes, so no bending the procedure
anymore for me...

Comment 12 Pete Zaitcev 2002-04-05 18:43:18 EST
The fix made beta4,
/pub/redhat/linux/rawhide/......
kernel-2.4.18-0.13.src.rpm.
Anyone is up for testing?
Comment 13 Brian Salomaki 2002-04-05 18:49:37 EST
I'll try that kernel out sometime this weekend after I upgrade to skipjack2 and
let you know.
Comment 14 Brian Salomaki 2002-04-15 15:25:13 EDT
OK, this appears to me to be fixed.  As long as nobody else is having problems,
it's resolved.

Note You need to log in before you can comment on or make changes to this bug.