Bug 618229 - RFE: ibus-setup: in the "Input Method" tab, display an IME configure button next to the IM name
RFE: ibus-setup: in the "Input Method" tab, display an IME configure button n...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-26 09:29 EDT by Harshula Jayasuriya
Modified: 2011-12-21 12:10 EST (History)
5 users (show)

See Also:
Fixed In Version: ibus-1.4.0-14.fc16
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-21 12:10:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harshula Jayasuriya 2010-07-26 09:29:00 EDT
Description of problem:

If an IME has a configuration option, then display a button to execute it in the "Input Method" tab alongside the IM name in the list of selected IMs. In some cases there maybe multiple IMs in the list from the same IME. In which case you could display an icon on the button to indicate a set of IMs belong to a particular IME.

Currently you need to first select an IM, activate the IM and then find the IME configure button. I suspect a user would want to configure the IME immediately after selecting the IM.

Apparently the IME configuration is activated by executing a separate binary. In the long term it maybe better for each IME to expose a configure/setup function directly via the IBus framework rather than create a separate binary.
Comment 1 fujiwara 2010-07-26 23:45:35 EDT
(In reply to comment #0)
> Apparently the IME configuration is activated by executing a separate binary.
> In the long term it maybe better for each IME to expose a configure/setup
> function directly via the IBus framework rather than create a separate binary.    

You might think a setup likes SCIM.
I think it's a bit difficult discussion.
You might think the combined setup is useful but I think the separated setup tools are useful because each engine setup has many configurations.
Personally I feel SCIM setup is too condensed.

technically, some IM engines have setups but others don't have. ibus-setup is based on Python so Python setups could be combined but C setup might need another wrapper.

Currently ibus panel icon's left click menu shows the engine setup menu and I think it's more useful than a part of ibus-setup.

One problem is, currently each engine sends the setup menu to ibus only when the IM is on. So even though if you always show ibus languagebar, the setup menu/icon is shown in case IM is on.

However your request might be possible to implement.
Let me think a little.
Comment 2 fujiwara 2010-07-27 04:07:16 EDT
This patch is an idea to add engine setup button:
http://github.com/fujiwarat/ibus/commit/8e573b5def7ea0f163efda900e19a39b7babe74c


Another idea is to modify engine description on engine about dialog.
e.g.
--- /usr/share/ibus/component/anthy.xml.orig	2010-07-27 11:44:06.000000000 +0900
+++ /usr/share/ibus/component/anthy.xml	2010-07-27 11:56:55.000000000 +0900
@@ -20,7 +20,8 @@
 			<icon>/usr/share/ibus-anthy/icons/ibus-anthy.png</icon>
 			<layout>jp</layout>
 			<longname>Anthy</longname>
-			<description>Anthy Input Method</description>
+			<description>Anthy Input Method
+Click &lt;a href=file:///usr/share/libexec/ibus-setup-anthy&gt;setup&lt;/a&gt; for the engine configuration.</description>
 			<rank>99</rank>
 		</engine>
 	</engines>
Comment 3 fujiwara 2010-07-28 03:40:27 EDT
I discussed this request today.
It still seems to need time.

I think there are two options:
#1 Continue to discuss the patch on upstream and wait upstream agrees with the patch.

#2 Integrate the current patch as a Fedora branding patch in rawhide (and f13?) and continue to discuss the patch on upstream. (It means we may will modify or delete the integrated patch in the future with the furthermore disucssion.)
Comment 4 Fedora Admin XMLRPC Client 2010-08-02 02:17:44 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 fujiwara 2010-08-06 04:13:18 EDT
Added libxklavier feature.
http://github.com/fujiwarat/ibus/commit/38b18273b2d2856ace1d0697470b71e0bc24d0e6
Comment 6 Harshula Jayasuriya 2010-08-10 02:35:40 EDT
Two weeks ago I tested RPMs created by Fujiwara containing the patch(es) that adds the preferences button to the "Input Method" tab. The "Input Method" tab looked good and the preferences button was where you would expect it.
Comment 7 fujiwara 2010-08-10 21:13:48 EDT
Oops, Comment #5 was for another bug.
I'll return to this after other priorities are resolved.
Comment 8 Akira TAGOH 2011-05-24 09:00:01 EDT
According to the comment #0, that sounds like a RFE since there are workaround to configure the IME options. so I've added a FutureFeature tag and moving back to rawhide.
Comment 9 Harshula Jayasuriya 2011-11-11 00:56:33 EST
Is this ever going to be fixed? Particularly considering there was a working fix back in 2010.
Comment 10 fujiwara 2011-11-25 05:49:22 EST
Now ibus_engine_desc_new_varargs() is supported so we can add the new property in engine xml files.
'<setup>' will be used additionally.
https://github.com/fujiwarat/ibus/commit/e7a722948025948f39ac8e7f9d5527a79f23c7ff
Comment 11 Fedora Update System 2011-11-28 04:09:10 EST
ibus-1.4.0-13.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ibus-1.4.0-13.fc16
Comment 12 Fedora Update System 2011-11-29 21:11:46 EST
ibus-1.4.0-14.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ibus-1.4.0-14.fc16
Comment 13 Fedora Update System 2011-12-06 00:03:09 EST
ibus-1.4.0-14.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ibus-1.4.0-14.fc16
Comment 14 Harshula Jayasuriya 2011-12-06 00:43:45 EST
When I press "Preferences" for "wijesekera (m17n)", I get the following in the terminal that I used to run ibus-setup:
---------------------------------------------
can't determine IBus engine name; use --name
---------------------------------------------

# rpm -qa | grep ^ibus | sort
ibus-1.4.0-14.fc16.x86_64
ibus-gnome3-1.4.0-14.fc16.x86_64
ibus-gtk2-1.4.0-14.fc16.x86_64
ibus-gtk3-1.4.0-14.fc16.x86_64
ibus-libs-1.4.0-14.fc16.x86_64
ibus-m17n-1.3.3-6.fc16.x86_64
Comment 15 fujiwara 2011-12-06 01:11:45 EST
(In reply to comment #14)
> When I press "Preferences" for "wijesekera (m17n)", I get the following in the
> terminal that I used to run ibus-setup:

Probably it's good to file a bug for ibus-m17n.
Comment 16 Harshula Jayasuriya 2011-12-08 00:40:55 EST
After updating ibus-m17n to Bug 760427 's koji build, it works.
Comment 17 Fedora Update System 2011-12-10 14:45:13 EST
Package ibus-1.4.0-14.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-1.4.0-14.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-16873/ibus-1.4.0-14.fc16
then log in and leave karma (feedback).
Comment 18 Fedora Update System 2011-12-21 12:10:04 EST
ibus-1.4.0-14.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.