Bug 61824 - control-center tries to start wmakerconf, which is no longer present
control-center tries to start wmakerconf, which is no longer present
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: control-center (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
David Lawrence
:
Depends On:
Blocks: 61590
  Show dependency treegraph
 
Reported: 2002-03-24 18:40 EST by Telsa Gwynne
Modified: 2007-04-18 12:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-25 16:34:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Telsa Gwynne 2002-03-24 18:40:51 EST
control-center "configure window manager" option for wmaker doesn't work: 
tries to run non-shipped program.

skipjack. control-center-1.4.0.1-25

How Reproducible: Always

Steps to Reproduce:
1. install including Window Maker as option.
2. Start Gnome. 
3. Main menu -> Settings -> Desktop -> Window manager -> select windowmaker
4. Hit "run configuration tool for Window Maker"

Nothing happens.

Console messages say wmakerconf: not found. Indeed, I don't see it on the
CDs. 

The fix is either to restore wmakerconf to the distribution, or to make it
run /usr/lib/GNUstep/Apps/WPrefs.app/WPrefs instead. (I cannot imagine why
it lives there, but since it does, you have to give the pathname because of
course it's not on PATH. )
Comment 1 Havoc Pennington 2002-03-24 22:25:22 EST
Bryce what's it supposed to run?
Comment 2 Havoc Pennington 2002-03-25 15:45:58 EST
Wow, WPrefs crashes all over the place. ;-) Plus can't load its defaults on
startup or something. 

What in the _world_ is it doing in /usr/lib? If WindowMaker is for GNUStep why
don't we just delete it until we start shipping GNUStep? ;-)
Comment 3 Phil Copeland 2002-03-25 16:33:58 EST
Ah,.. well having poped around to see what you were at, you were running a
totally busted version of windowmaker
should have been 0.80.0-7
any 0.80.1 stuff that you may have is  just plain *wrong*

Phil
=--=
Comment 4 Havoc Pennington 2002-03-25 16:51:19 EST
control-center 1.4.0.1-26 changes the config tool

Note You need to log in before you can comment on or make changes to this bug.