Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 618242 - position of mouse pointer displayed in the spicec is different from real mouse pointer position on guest
position of mouse pointer displayed in the spicec is different from real mous...
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-client (Show other bugs)
6.0
All All
low Severity medium
: rc
: ---
Assigned To: Arnon Gilboa
Desktop QE
: RHELNAK
Depends On:
Blocks: 626721
  Show dependency treegraph
 
Reported: 2010-07-26 09:41 EDT by Lubos Kocman
Modified: 2013-08-25 20:30 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 626721 (view as bug list)
Environment:
Last Closed: 2010-11-08 06:12:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spicec.log (41.88 KB, application/octet-stream)
2010-07-26 09:42 EDT, Lubos Kocman
no flags Details
qemu-kvm.out (3.53 KB, application/octet-stream)
2010-07-26 09:42 EDT, Lubos Kocman
no flags Details

  None (edit)
Description Lubos Kocman 2010-07-26 09:41:35 EDT
Description of problem:

I found that mouse coordinates become somehow garbled after changing resolution from lower to higher.

I was able to reproduce this issue on Win7 guest with 2 displays. I'll try to find out how much system/display specific the issue is.

Version-Release number of selected component (if applicable):

spice-server-0.4.2-14.el6.x86_64
spice-client-0.4.2-15.el6.x86_64
qemu-kvm-0.12.1.2-2.96.el6.x86_64

Guest contains software installed from RHEV-toolsSetup_2.2_46140 media



How reproducible:


Steps to Reproduce:
1. sudo /usr/libexec/qemu-kvm -vga qxl -device qxl  -m 1024 -spice port=3001,disable-ticketing -usbdevice table <win7.img>
2. /usr/libexec/spicec  --host localhost --port 3001
3. change resolution of gues from lower to higher (in my case 1024x768 -> 1440x900)

Actual results:
Both (x,y) coordinates seems to be dependent on distance from upper left corner of primary display (0,0)

I think that it behaves like (x += x, y+=y)

Expected results:

Displayed position of the cursor should be equal to the real position.


Additional info:

Display coordinates seems to be like (x += x, y+=y) from upper left corner of the primary display.
Comment 1 Lubos Kocman 2010-07-26 09:42:14 EDT
Created attachment 434418 [details]
spicec.log
Comment 3 Lubos Kocman 2010-07-26 09:42:39 EDT
Created attachment 434419 [details]
qemu-kvm.out
Comment 4 RHEL Product and Program Management 2010-07-26 09:57:52 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 6 Uri Lublin 2010-08-12 12:22:50 EDT
Hi Lubos,

Please retry with the following in mind:
1. Do not use -usbdevice tablet when running with multi-monitor spice.
2. Use spice-vmc device (-device virtio-serial -device spicevmc,nr=0)
3. Install qxl driver on guest
4. Install spice-vmc driver on guest
5. Install appropriate vdagent and vdservice (they are not the same as in
   RHEV-2.2, adjusting to the new spicevmc device)
6. Make sure vdservice and vdagent are running
   - start -> run -> cmd  +   net start vdservice  (or check the logs)


Following the above, with a Win XP guest, I could not reproduce the bug.

Ping me on IRC if you need any help.

Thanks.
Comment 9 Lubos Kocman 2010-11-08 06:12:03 EST
This issue has not been reproduced  on el6 any more.

Note You need to log in before you can comment on or make changes to this bug.