Bug 618332 - CPUID_EXT_POPCNT enabled in qemu64 and qemu32 built-in models.
CPUID_EXT_POPCNT enabled in qemu64 and qemu32 built-in models.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: john cooper
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-26 13:12 EDT by john cooper
Modified: 2014-07-24 23:46 EDT (History)
9 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.107.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 16:26:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description john cooper 2010-07-26 13:12:46 EDT
Description of problem:

Upstream qemu commit 910628f39676ee65211727245809eec7ca4d75f5 adds
POPCNT to qemu64/qemu32.  This can break migration when using
these guest models should migration be attempted to a cpu lacking
this feature.

How reproducible:

    # /usr/libexec/qemu-kvm -cpu ?dump
  
Actual results:

x86         [qemu64]  QEMU Virtual CPU version 0.12.1                 
     :
  feature_ecx 00802001 (popcnt cx16 pni|sse3)


x86         [qemu32]  QEMU Virtual CPU version 0.12.1                 
     :
  feature_ecx 00800001 (popcnt pni|sse3)


Expected results:

"popcnt" should not be present.

Additional info:

The addition of popcnt to what is intended as a least common
denominator seems rather odd, as only select CPUs support this
feature.  This was specifically enabled by the commit called
out above and understanding what motivated this change needs
to be part of the case resolution.
Comment 2 RHEL Product and Program Management 2010-07-26 13:37:42 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 4 Avi Kivity 2010-07-26 15:29:31 EDT
Not just popcnt, the other flags should be reviewed against hardware in the field.
Comment 9 Miya Chen 2010-08-10 04:33:09 EDT
Tested with qemu-kvm-0.12.1.2-2.108.el6,
1. # /usr/libexec/qemu-kvm -cpu ?dump
x86      cpu64-rhel5  QEMU Virtual CPU version (cpu64-rhel5)          
            :
  feature_ecx 00000001 (pni|sse3)
            :
x86      cpu64-rhel6  QEMU Virtual CPU version (cpu64-rhel6)          
            :
  feature_ecx 00002001 (cx16 pni|sse3)
            :

2. Boot guest with -M rhel6.0.0 & -M rhel5.5.0 & -M rhel5.4.4 & -M rhel5.4.0, guest can be boot up successfully with related cpu model.
cmd:
# /usr/libexec/qemu-kvm -m 4G -smp 2 -monitor stdio -drive file=/home/RHEL-Server-6.0-64-virtio.qcow2,if=none,format=qcow2,boot=on,cache=none,id=test -device virtio-blk-pci,drive=test -device virtio-net-pci,mac=20:20:20:12:23:15,netdev=hostnet0 -netdev tap,script=/etc/qemu-ifup,vhost=on,id=hostnet0 -usbdevice tablet -vnc :10 -M xxxx

Based on above, change status to verified.
Comment 10 releng-rhel@redhat.com 2010-11-10 16:26:56 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.