Bug 61834 - Bad colors on a Trident Cyber 9388
Summary: Bad colors on a Trident Cyber 9388
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: skipjack-beta1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-25 02:22 UTC by ajs
Modified: 2007-04-18 16:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-12 20:26:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My XF86Config file (4.84 KB, text/plain)
2002-03-25 02:26 UTC, ajs
no flags Details
/var/log/XFree86.0.log (631.40 KB, text/plain)
2002-03-28 15:26 UTC, ajs
no flags Details
Screenshot (71.70 KB, image/jpeg)
2002-03-28 15:28 UTC, ajs
no flags Details
/var/log/XFree86.0.log in 8 bit mode (88.41 KB, text/plain)
2002-03-28 22:34 UTC, ajs
no flags Details

Description ajs 2002-03-25 02:22:24 UTC
Description of Problem:
  The colors when using the trident driver on a Trident Cyber 9388 are
  horrible.

Actual Results:
  Lots of psychedelic yellows.

Expected Results:
  Something less painful on the orbs.

Additional Information:
  NEC Versa SX 440
  Trident Cyber 9388

  Worked fine on enigma XFree86 4 server.

Comment 1 ajs 2002-03-25 02:26:08 UTC
Created attachment 50064 [details]
My XF86Config file

Comment 2 Mike A. Harris 2002-03-28 15:14:28 UTC
Can you please attach your X server log, and also a screenshot of the problem?
The screenshot might not help much displayed on other hardware, but it
is worth a shot anyways...

Comment 3 Alan Hourihane 2002-03-28 15:17:40 UTC
This smells of a similar problem on 9397's

A fix is in the works.

Comment 4 ajs 2002-03-28 15:26:55 UTC
Created attachment 51185 [details]
/var/log/XFree86.0.log

Comment 5 ajs 2002-03-28 15:28:53 UTC
Created attachment 51188 [details]
Screenshot

Comment 6 ajs 2002-03-28 15:30:32 UTC
Bummer.  The screenshot looks fine when viewed from another computer.

Comment 7 ajs 2002-03-28 22:32:42 UTC
I tried 8 bit mode and things are bearable now.

16 bit with the latest skipjack version (4.2.0-6.48) was still bad.

See also https://listman.redhat.com/pipermail/skipjack-list/2002-March/000550.html.

I'l attach the server log in a sec.

Comment 8 ajs 2002-03-28 22:34:03 UTC
Created attachment 51227 [details]
/var/log/XFree86.0.log in 8 bit mode

Comment 9 D. Hugh Redelmeier 2002-03-29 21:08:55 UTC
I've got an NEC Versa SX (with PII 233 CPU -- earlier than 440; uses 9388).  I'm
running RHL7.2 with the standard updates.  I run with depth 16.  X mostly behaves.  

I noticed that some (very few) pixels get misplaced in Xterm.  It depends on a
variety of things that I haven't characterized.  The font chosen seems to have
an effect -- problem seems to be reduced with xterm's "medium" vs "default". 
Inverse video or bold face characters in window seem to be a catalyst for the
problem.  The damage disappears when the window is covered by another and then
uncovered again.  The damage is more often on the right side of the window.

Yesterday, X came up with some brown as the background colour for xterm and
menus.  Very odd.  Fixed by reboot.

Comment 10 Mike A. Harris 2002-04-06 02:50:15 UTC
Can you try out 4.2.0-6.60 and provide feedback if this problem is still
present in the new package.

TIA

Comment 11 ajs 2002-04-06 22:22:10 UTC
I can't find 4.2.0-6.60.  I tried up2date -l and your
testing/bleeding-edge/XFree86 directory on people.redhat.com.  I have 
4.2.0-6.52 installed and I still have problems.  Some of the colors look OK
though.  The grays in the default color scheme for GNOME look OK.  The sky in
the lighthouse splashscreen at GNOME startup looks OK.  The green and red in the
RHN monitor applet look good.  The red in the Mozilla logo looks green and the
red in the Red Hat gdm logo looks violet.

Comment 12 ajs 2002-04-12 20:26:34 UTC
I did a real boot to Windows today (rather than VMware) and the colors look
similar in Windows as they do with 4.2.0-6.52.  I have access to another VersaSX
with only Windows on the HD.  I will try and switch the hard drives sometime
during the next few days and verify that my remaining problem is in the hardware.  

Does anyone else have a VersaSX and can test the new RPM?


Comment 13 ajs 2002-04-16 15:00:25 UTC
It works with 4.2.0-6.62.



Note You need to log in before you can comment on or make changes to this bug.