Bug 6184 - hwclock on Alpha may need recent clock patches for Jensen
hwclock on Alpha may need recent clock patches for Jensen
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: clock (Show other bugs)
6.1
alpha Linux
low Severity low
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-21 09:20 EDT by mchampig
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-10-27 15:16:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mchampig 1999-10-21 09:20:38 EDT
This is more a heads-up than a bug report. I've heard that
the maintainer of hwclock has ported some patches from
clock which fixes Jensen bugs. Recently you've put together
a clock-1.1-7 package (which works on the Jensen). Please
let the hwclock maintainer know about the recent fixes
so that hwclock can be kept in sync. Maybe you can get rid
of clock forever once hwclock has all the bells and
whistles. This would streamline the init scripts a little
too.
Comment 1 Bill Nottingham 1999-10-21 16:05:59 EDT
Hmm... if you change line 327 (or so) of the latest util-linux
from:

 cmos_write(10, (save_freq_select | 0x70));

to

 cmos_write(10, (save_freq_select | clock_ctl_addr));

does the util-linux hwclock then work for you?
Comment 2 mchampig 1999-10-25 09:49:59 EDT
Actually, in this case you want the 0x70 because this is used as
a bitmask...not a clock address! This was the same bug fixed in
the Jensen patch to the clock. It should always be 0x70 regardless
of the Alpha platform it's running on.
Comment 3 mchampig 1999-10-27 09:26:59 EDT
The hwclock in Bill's util-linux-2.9w works fine on all the Alpha's
I tested on, including Jensen. I think this one can be relegated
to "NEXTRELEASE". :-)
Comment 4 Bill Nottingham 1999-10-27 15:16:59 EDT
Fixed in util-linux-2.9w-26, initscripts-4.59, timeconfig-3.0.2-1.

Note You need to log in before you can comment on or make changes to this bug.