This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 61840 - Installer threw exception when attempting to start upgrading
Installer threw exception when attempting to start upgrading
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-25 00:01 EST by fyuen
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-28 17:21:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description fyuen 2002-03-25 00:01:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Win 9x 4.90)

Description of problem:
After upgrading window 98 to window-me, I lost LILO.  I followed resolution as 
documented in http://kb.redhat.com/view.php?eid=94 to do an upgrade.  After 
selecting create boot disk and create LILO, the installer started the upgrade 
process.  Then it threw an exception and asked me to report a bug.  The message 
was:
Traceback (innermost last):
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/iw/progress_gui.py", line 19, 
in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 2081, in 
doInstall
    self.hdList, self.upgrade, langlist)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/lilo.py", line 277, in install
    lilo.read (instRoot + '/etc/lilo.conf')
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/lilo.py", line 140, in read
    if image: self.addImage(image)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/lilo.py", line 79, in addImage
    config.getEntry('label')
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/lilo.py", line 54, in getEntry
    return self.items[item]
KeyError: label

Local variables in innermost frame:
self: root="/dev/hdb8"
append="hdc=ide-scsi"

item: label

ToDo object:
(itodo
ToDo
p1
(dp2
S'resState'
p3
S''
sS'progressWindow'
p4
(igui
ProgressWindow
(dp5
S'total'
p6
I0
sS'window'
p7
(igtk
GtkWindow
(dp8
S'_o'
p9

<failed>


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start installer using CD-ROM
2.Follow instructions to upgrade
3.On the page to create LILO, select create boot disk and create LILO.  Choose 
install LILO boot record on dev/hda MBR.  Whether selecting default boot 
partition to be dos or linux did not change the result (i.e. same exception 
threw).
4. Select "next"

	

Actual Results:  Installer started to process.  Then exception was thrown.

Expected Results:  Installer should continue to start upgrading.

Additional info:

I also tried to use the boot disk to boot.  It failed to boot up.  So I cannot 
get into Linux at all.
Comment 1 Jeremy Katz 2002-03-25 19:10:31 EST
The instructions do not say to do a complete upgrade installation; instead, you
should run lilo prior to the install completing.  But, what did your
/etc/lilo.conf look like since it appears it got misparsed (or was invalid and
we didn't catch the fact that it was invalid)
Comment 2 fyuen 2002-03-25 19:54:10 EST
Since I cannot boot into Linux, I cannot tell what is in /etc/lilo.conf.
I used CD-ROM to start up the installer and then selected option for every 
question the installer prompted.  There was no option for me to run LILO.  
There was an option to whether create LILO and I selected this option.  I then 
selected "next".  The installer started to do some processing and then threw 
the exception as described.
Comment 3 Jeremy Katz 2002-03-28 17:38:48 EST
You have to go to tty2 from the installer to run lilo.  The installer does not
provide this as an option.  

At this point, this is not a bug and as bugzilla is not a support forum, for
further support, you will either need to contact our support organization or ask
on a general mailing list such as enigma-list
(https://listman.redhat.com/mailman/listinfo/enigma-list) or redhat-list.

Note You need to log in before you can comment on or make changes to this bug.