Bug 618417 - wrong requires in mock
Summary: wrong requires in mock
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: mock   
(Show other bugs)
Version: el6
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Clark Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-26 21:30 UTC by Levente Farkas
Modified: 2013-01-10 06:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-28 13:52:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
empty test rpm (1.95 KB, application/x-rpm)
2010-07-27 22:09 UTC, Levente Farkas
no flags Details
mock config file (650 bytes, application/octet-stream)
2010-07-27 22:11 UTC, Levente Farkas
no flags Details

Description Levente Farkas 2010-07-26 21:30:14 UTC
if you try to build this src.rpm:
http://koji.fedoraproject.org/koji/buildinfo?buildID=179409
with mock-1.1.1 it's not build while the current epel builder 1.0.8 built it. the reason is somewhere between mock and yum. while running with 1.1.1 it's install java-1.5.0-gcj-devel even if the 
BuildRequires:  java-devel >= 1:1.6.0
and even if the system install java-1.6.0-openjdk.i686. so why it's install gcj too? the strange thing that this bug do not exists in 1.0.8 (just see my epel build's log).

Comment 1 Levente Farkas 2010-07-27 10:43:12 UTC

*** This bug has been marked as a duplicate of bug 618427 ***

Comment 2 Levente Farkas 2010-07-27 20:52:49 UTC
it seems to be a bug in mock and not yum and also happened with mock-1.0.8 too but only on rhel-6 beta2 update 1.

Comment 3 Clark Williams 2010-07-27 21:42:31 UTC
What command line are you using to build the above SRPM?

Also, are you saying that this only happens if the build host is a RHEL6 beta2 update1 system?

Comment 4 Levente Farkas 2010-07-27 22:09:03 UTC
so the setup:
- install the latest rhel6
- install mock (either 1.0.8 or 1.1.1) and ccache from epel
- try to simple new mock cfg file for the new build (see the attached one)
and build the attached empty src.rpm.

Comment 5 Levente Farkas 2010-07-27 22:09:27 UTC
Created attachment 434869 [details]
empty test rpm

Comment 6 Levente Farkas 2010-07-27 22:11:09 UTC
Created attachment 434870 [details]
mock config file

edit the groups repo to point to a repo which contain a good comps.xml

Comment 7 Levente Farkas 2010-07-27 22:12:01 UTC
anyway it can be another bug why rhel-6 still not contain buildsys-build in it's comps.xml....

Comment 8 Levente Farkas 2010-07-28 13:52:52 UTC
sorry it seems i try to build on rhel-6 beta1. after i update to rhel-6 beta2 update1 everything is working again.


Note You need to log in before you can comment on or make changes to this bug.