Bug 618420 - [abrt] crash in rakarrack-0.5.8-2.fc12: Process /usr/bin/rakarrack was killed by signal 6 (SIGABRT)
Summary: [abrt] crash in rakarrack-0.5.8-2.fc12: Process /usr/bin/rakarrack was killed...
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: rakarrack   
(Show other bugs)
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: David Timms
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:7d756e899460d745b0e1840c7b5...
Keywords:
: 641164 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-26 21:47 UTC by kajetan.drozd
Modified: 2010-10-08 22:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-27 13:55:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (9.05 KB, text/plain)
2010-07-26 21:47 UTC, kajetan.drozd
no flags Details

Description kajetan.drozd 2010-07-26 21:47:05 UTC
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: rakarrack
comment: i try use rock amp
component: rakarrack
executable: /usr/bin/rakarrack
global_uuid: 7d756e899460d745b0e1840c7b50fd24583e7647
kernel: 2.6.32.14-127.fc12.x86_64
package: rakarrack-0.5.8-2.fc12
rating: 4
reason: Process /usr/bin/rakarrack was killed by signal 6 (SIGABRT)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1. try to change preset from bank
2.
3.

Comment 1 kajetan.drozd 2010-07-26 21:47:11 UTC
Created attachment 434536 [details]
File: backtrace

Comment 2 David Timms 2010-07-27 13:55:19 UTC
Hi Kajetan,

Rakarrack preset 17 Hard rock amp is a preset that uses the Convolotron effect. Even with decent CPU speeds, it is set with values that will cause calculations that don't complete quickly enough to keep the audio real-time, and will lead to the crash you have seen.

This is known upstream, and while I would hope that future development would attempt to detect that issue and warn nicely, perhaps turning off effect, or similar. In the meantime, trying the safe mode button, and reducing the oversampling quality in the preferences may allow this effect to work on your machine.

The upstream response is:
<http://sourceforge.net/tracker/?func=detail&aid=3030872&group_id=215888&atid=1035482> . Closing the bug as upstream, although if anyone can provide patches to resolve the problem, either post them here or the upstream bug.

You can learn more about the DSP processing by reading the help file (Help|Help Contents|General), heading "Warning".

Another approach might to use rakarrack with jack running on a real-time patched kernel (eg planetCCRMA).

Comment 3 David Timms 2010-10-08 08:25:57 UTC
*** Bug 641164 has been marked as a duplicate of this bug. ***

Comment 4 Ian Malone 2010-10-08 13:32:16 UTC
Thanks for the update, abrt makes it very easy to report a bug without checking first... is there any way for it to recognise a crash? I do find upstream's "You can learn more about..." rather amusing.

Comment 5 David Timms 2010-10-08 22:40:25 UTC
(In reply to comment #4)
> Thanks for the update, abrt makes it very easy to report a bug without checking
> first... is there any way for it to recognise a crash?
Usually abort's abrt_hash is used to detect duplicate crashes, and it then attaches to existing report.

I guess the backtrace was different enough (hence possibly died at a different point), that it created a different hash.


Note You need to log in before you can comment on or make changes to this bug.