Bug 618422 - Wrong handling of devices with more than 2 valuators
Wrong handling of devices with more than 2 valuators
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Peter Hutterer
desktop-bugs@redhat.com
: Regression
Depends On:
Blocks: 607150
  Show dependency treegraph
 
Reported: 2010-07-26 17:54 EDT by Peter Hutterer
Modified: 2010-11-10 16:59 EST (History)
2 users (show)

See Also:
Fixed In Version: xorg-x11-server-1.7.7-22.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 16:59:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Hutterer 2010-07-26 17:54:51 EDT
Description of problem:
Fix to Bug 607150 introduces a regression in the handling of devices with more than two axes. A full description of (and proposed fix for) the issue is available here:
http://lists.freedesktop.org/archives/xorg-devel/2010-July/011355.html

Version-Release number of selected component (if applicable):
xorg-x11-server-1.7.7-17.el6

How reproducible:
Reproducible by using e.g. a wacom tablet and generating button releases on the
tablet - the log will fill up with "too many valuators" error messages.
Comment 3 Peter Hutterer 2010-07-28 01:54:46 EDT
MODIFIED

xorg-x11-server-1.7.7-22.el6 is available in brew.
Comment 5 Mark Gordon 2010-08-16 14:16:30 EDT
Verified with a Lenovo T60 and a Wacom PTK-440.  Installed an old compose that had the broken version to confirm that I could reproduce the bug, then installed a recent compose with the fix to confirm that I could no longer reproduce the bug.  Confirmed that the bug is fixed in both i686 and x86_64.

-> VERIFIED
Comment 6 releng-rhel@redhat.com 2010-11-10 16:59:09 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.