Bug 61848 - Conflict between function and alias crashes zsh
Summary: Conflict between function and alias crashes zsh
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: zsh (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-25 08:37 UTC by Jan Iven
Modified: 2007-04-18 16:41 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-25 21:18:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jan Iven 2002-03-25 08:37:38 UTC
Description of Problem:


Defining an alias and a shell function with the same name and trying to
execute it crashes ZSH shell.

Version-Release number of selected component (if applicable):

zsh-4.0.2-2

How Reproducible:

always.

Steps to Reproduce:
    [lxshare002d] /home/test > zsh
    [lxshare002d] ~ % alias xx='echo ALIAS'
    [lxshare002d] ~ % xx
    ALIAS
    [lxshare002d] ~ % xx()
    function> { echo FUNC }
    [lxshare002d] ~ % which xx
    xx: aliased to echo ALIAS
    [lxshare002d] ~ % xx
    Segmentation fault

Actual Results:

crash, backtrace looks rather recursive...


Expected Results:

either function or alias results, or at least an error message..

Additional Information:

Comment 1 Trond Eivind Glomsrxd 2002-03-25 21:18:06 UTC
A problem with 4.0.4.. reported upstream.

Comment 2 Trond Eivind Glomsrxd 2002-03-26 00:01:25 UTC
Not a bug, read http://zsh.sunsite.dk/FAQ/zshfaq02.html#23


Note You need to log in before you can comment on or make changes to this bug.