Bug 618481 - Intel HD Graphics is not working on laptop with hybrid Graphics (Other is Nvidia)
Summary: Intel HD Graphics is not working on laptop with hybrid Graphics (Other is Nvi...
Status: CLOSED DUPLICATE of bug 596557
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel   
(Show other bugs)
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-27 02:27 UTC by A S Alam
Modified: 2018-04-11 13:07 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-26 13:41:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages attached (2.41 MB, text/plain)
2010-07-29 13:36 UTC, A S Alam
no flags Details
dmesg file when xorg.conf -> driver intel (44.88 KB, text/plain)
2010-07-29 13:37 UTC, A S Alam
no flags Details
xorg.conf with intel, which is not working (Screen flickering) (1.14 KB, text/plain)
2010-07-29 13:38 UTC, A S Alam
no flags Details
Xorg.0.log (7.04 KB, text/plain)
2010-07-29 13:39 UTC, A S Alam
no flags Details
Xorg.1.log (7.04 KB, text/plain)
2010-07-29 13:40 UTC, A S Alam
no flags Details
Xorg.2.log (7.04 KB, text/plain)
2010-07-29 13:41 UTC, A S Alam
no flags Details
Xorg.3.log (7.04 KB, text/plain)
2010-07-29 13:42 UTC, A S Alam
no flags Details
Xorg.4.log (7.04 KB, text/plain)
2010-07-29 13:43 UTC, A S Alam
no flags Details
Xorg.5.log (7.04 KB, text/plain)
2010-07-29 13:43 UTC, A S Alam
no flags Details
Xorg.setup.log (1.76 KB, text/plain)
2010-07-29 13:46 UTC, A S Alam
no flags Details

Description A S Alam 2010-07-27 02:27:27 UTC
Description of problem:
Laptop has Dynamic Hybrid Graphics with following detail:
-------- 
[root@zhawk ~]# lspci |grep VGA
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation GT216 [GeForce GT 330M] (rev a2)
--------
3 mode with Hardware Switch/Button
1 - Speed (NVIDIA® GeForce® GT 330M GPU)
2 - Stamina (Intel® HD Graphics)
3 - Auto

for Testing, used Speed/Stamina Mode only.

Specification: 

Version-Release number of selected component (if applicable):
xorg-x11-drv-intel-2.11.0-5.fc13.x86_64
kernel-2.6.33.6-147.fc13.x86_64

How reproducible:
always

Steps to Reproduce:
1. setting 'intel' driver in xorg.conf is not working, no Display

  
Actual results:
only 'vesa' is working,


Expected results:
setting 'intel' should work

Additional info:
for Nvidia Display Problem Bug #610496 filed

VGA.rom: https://bugzilla.redhat.com/attachment.cgi?id=431632 (which suppose to be Intel GPU )

Comment 2 Matěj Cepl 2010-07-27 21:52:48 UTC
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please add drm.debug=0x04 to the kernel command line, restart computer, and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* X server log file (/var/log/Xorg.*.log)
* output of the dmesg command, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 3 A S Alam 2010-07-29 13:36:52 UTC
Created attachment 435280 [details]
/var/log/messages attached

Comment 4 A S Alam 2010-07-29 13:37:48 UTC
Created attachment 435281 [details]
dmesg file when xorg.conf -> driver intel

Comment 5 A S Alam 2010-07-29 13:38:49 UTC
Created attachment 435282 [details]
xorg.conf with intel, which is not working (Screen flickering)

Comment 6 A S Alam 2010-07-29 13:39:26 UTC
Created attachment 435283 [details]
Xorg.0.log

Comment 7 A S Alam 2010-07-29 13:40:28 UTC
Created attachment 435285 [details]
Xorg.1.log

Comment 8 A S Alam 2010-07-29 13:41:47 UTC
Created attachment 435287 [details]
Xorg.2.log

Comment 9 A S Alam 2010-07-29 13:42:53 UTC
Created attachment 435289 [details]
Xorg.3.log

Comment 10 A S Alam 2010-07-29 13:43:21 UTC
Created attachment 435290 [details]
Xorg.4.log

Comment 11 A S Alam 2010-07-29 13:43:45 UTC
Created attachment 435291 [details]
Xorg.5.log

Comment 12 A S Alam 2010-07-29 13:46:52 UTC
Created attachment 435294 [details]
Xorg.setup.log

Comment 13 Adam Jackson 2010-08-26 13:41:22 UTC
Intel's not going to work if you say 'nomodeset'.  Try not doing that.

Comment 14 Adam Williamson 2010-08-26 18:12:02 UTC
ajax, it is a bug, it's a dupe of mine that I emailed you about. It doesn't work without 'nomodeset', either.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 596557 ***


Note You need to log in before you can comment on or make changes to this bug.