Bug 618498 - libvirtd fails to start
libvirtd fails to start
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-27 01:13 EDT by Conrad Meyer
Modified: 2011-02-04 11:47 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-04 11:47:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Conrad Meyer 2010-07-27 01:13:24 EDT
Description of problem:
the libvirtd service won't start (stock F-13 system).


Version-Release number of selected component (if applicable):
libvirt-0.7.7-5.fc13.x86_64


How reproducible:
always


Steps to Reproduce:
1. libvirtd as root
2.
3.
  
Actual results:
22:11:40.067: warning : qemudStartup:1150 : Unable to create cgroup for driver: No such device or address
22:11:40.301: warning : lxcStartup:1748 : Unable to create cgroup for driver: No such device or address
22:11:40.320: error : virStateInitialize:890 : Initialization of UML state driver failed
22:11:40.320: error : main:3160 : Driver state initialization failed
22:11:40.321: warning : qemudDispatchSignalEvent:385 : Shutting down on signal 3


Expected results:
(libvirtd starts)

Additional info:
selinux in enforcing mode, no AVC denials. i'll be gone for a week without access to this machine, but after that i should be able to answer any questions you may have. sorry about the timing.

also, got this line in /var/log/messages: Jul 26 21:48:25 localhost libvirtd: Could not find keytab file: /etc/libvirt/krb5.tab: No such file or directory
Comment 1 Luc de Louw 2010-09-28 04:09:27 EDT
Add the following to /etc/fstab and libvirtd works again:

cgroup /cgroup cgroup  cpuset,cpu,cpuacct,memory,devices,freezer,net_cls
Comment 2 Stefan Berger 2011-02-04 10:41:25 EST
I had a similar problem. The reason on my machine was a corrupted qemu binary (some linklib was missing) that libvirt was trying to probe while starting. I believe I found it with 

export LIBVIRT_DEBUG=1

skipping over the iptables errors that libvirt tolerates to fail.
Comment 3 Conrad Meyer 2011-02-04 11:47:28 EST
libvirtd has gone back to working for me since I filed this (without any action on my part other than installing updates). go figure.

Note You need to log in before you can comment on or make changes to this bug.