Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 618510 - Unable to compile kernel
Unable to compile kernel
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-27 02:15 EDT by Thomas Spear
Modified: 2010-08-03 12:56 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-03 07:34:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Spear 2010-07-27 02:15:15 EDT
Description of problem:
Unable to build kernel or external modules

Version-Release number of selected component (if applicable):
2.6.33.6-147.fc13.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Install gcc and kernel-devel plus all dependencies
2. cd /usr/src/kernels/2.6.33.6-147.fc13.x86_64
3. make mrproper
  
Actual results:
[root@tom 2.6.33.6-147.fc13.x86_64]# make mrproper
scripts/Makefile.clean:17: /usr/src/kernels/2.6.33.6-147.fc13.x86_64/drivers/infiniband/hw/amso1100/Makefile: No such file or directory
make[3]: *** No rule to make target `/usr/src/kernels/2.6.33.6-147.fc13.x86_64/drivers/infiniband/hw/amso1100/Makefile'.  Stop.
make[2]: *** [drivers/infiniband/hw/amso1100] Error 2
make[1]: *** [drivers/infiniband] Error 2
make: *** [_clean_drivers] Error 2
[root@tom 2.6.33.6-147.fc13.x86_64]# 

Expected results:
Makes a clean source directory for compiling.

Additional info:

/proc/config.gz does not exist either so cannot make oldconfig as I've been previously able to.

Also receive errors using the NVidia driver installer which was working in the past, logs indicate it is because kernel sources are not properly setup (build has not been done yet).

*NOTE: This is a fresh install done 2 days ago with all of the latest updates.
**NOTE: I am about to test the updates-testing kernel and see if anything improves.
***NOTE: Nouveau is blacklisted as it does not work well with wine and 3d games in Windows. Using wine-1.2 from stable repo.
Comment 1 Thomas Spear 2010-07-27 02:19:29 EDT
updates-testing kernel does not build either, same error:

[tom@tom 2.6.33.6-147.2.4.fc13.x86_64]$ make mrproper
scripts/Makefile.clean:17: /usr/src/kernels/2.6.33.6-147.2.4.fc13.x86_64/drivers/infiniband/hw/amso1100/Makefile: No such file or directory
make[3]: *** No rule to make target `/usr/src/kernels/2.6.33.6-147.2.4.fc13.x86_64/drivers/infiniband/hw/amso1100/Makefile'.  Stop.
make[2]: *** [drivers/infiniband/hw/amso1100] Error 2
make[1]: *** [drivers/infiniband] Error 2
make: *** [_clean_drivers] Error 2

End result is that I cannot use the Nvidia driver, thereby resulting in the inability to use wine for gaming.
Comment 2 Thomas Spear 2010-08-02 20:36:26 EDT
Any updates?
Comment 3 Neil Horman 2010-08-03 07:34:16 EDT
Yeah, you're doing it wrong :)

The place you're trying to build in just contains the kernel headers (for the purposes of building external modules, or user apps that require exported kernel specific info).  If you want to build a kernel you need to download the kernel source rpm, install and build that.
Comment 4 Thomas Spear 2010-08-03 11:14:35 EDT
2 things:

1) I am trying to build the nvidia binary module, and that is failing so I figured I would try to see what is going wrong.

2) I see no kernel-source in any of the repos and I've installed all of the other kernel packages like kernel-devel kernel-debuginfo etc. So where do I get the kernel-source rpm from?
Comment 5 Thomas Spear 2010-08-03 12:19:06 EDT
After removing the updates-testing kernel, kernel-devel and kernel-headers and reinstalling them from updates, and downloading the new nvidia driver, I was able to get it to compile without issue.

Note You need to log in before you can comment on or make changes to this bug.