Bug 618517 - cdrom_id fails to find a root device on livecd-creator made LiveCD image booted within Qemu
cdrom_id fails to find a root device on livecd-creator made LiveCD image boot...
Status: CLOSED DUPLICATE of bug 609049
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-27 03:11 EDT by Jasper O'neal Hartline
Modified: 2010-07-27 03:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-27 03:44:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jasper O'neal Hartline 2010-07-27 03:11:06 EDT
Description of problem:
cdrom_id fails to find a root device on livecd-creator made LiveCD image booted within Qemu

Version-Release number of selected component (if applicable):
udev-160-8.fc14.i686.rpm

How reproducible:


Steps to Reproduce:
1. Make a LiveCD with a RAWHIDE repo ( Date: 7/27/2010 )
2. Boot within qemu
3. See cdrom_id hang for a while then finally boot failed sleeping forever.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jasper O'neal Hartline 2010-07-27 03:15:06 EDT
Actually, this bug only presents it's self when you use livecd-creator -c livecd.ks -f rawhide.iso as the label, apparently the ISOLINUX.cfg which is written writes root device as rawhide.iso which is why it fails, not rawhide.iso.iso

Possible bug in livecd-creator in it's processing of filenames and labels.
Will look at it.
Comment 2 Jasper O'neal Hartline 2010-07-27 03:19:25 EDT
Furthermore, booting it in VirtualBox, it boots fine.
As I stated, in Qemu, it doesn't boot using qemu -cdrom rawhide.iso.iso
Comment 3 Harald Hoyer 2010-07-27 03:44:18 EDT
see bug 609049

use:

"-drive file=xyz.iso,if=scsi,media=cdrom"
Comment 4 Harald Hoyer 2010-07-27 03:44:48 EDT

*** This bug has been marked as a duplicate of bug 609049 ***

Note You need to log in before you can comment on or make changes to this bug.