Bug 618535 - UI is not populated correctly when using "Add Advanced Target" button to add a multipath device
UI is not populated correctly when using "Add Advanced Target" button to add ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
s390x Linux
low Severity medium
: rc
: ---
Assigned To: David Cantrell
Release Test Team
:
Depends On:
Blocks: 670159
  Show dependency treegraph
 
Reported: 2010-07-27 04:26 EDT by Jan Stodola
Modified: 2011-12-06 05:26 EST (History)
3 users (show)

See Also:
Fixed In Version: anaconda-13.21.130-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 05:26:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
multipath zfcp added using "Add Advanced Target" button (225.20 KB, image/png)
2010-07-27 04:31 EDT, Jan Stodola
no flags Details
sys.tar.gz (110.27 KB, application/x-gzip)
2011-08-08 04:27 EDT, Jan Stodola
no flags Details
DASD devices listed twice (166.95 KB, image/png)
2011-08-17 04:48 EDT, Jan Stodola
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1565 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2011-12-05 19:39:12 EST

  None (edit)
Description Jan Stodola 2010-07-27 04:26:29 EDT
Description of problem:
When adding (zfcp) multipath device using "Add Advanced Target" button, UI is not populated correctly. There will be an example of adding one zfcp multipath LUN (connected via two paths). This issue happens only when using the "Add Advanced Target" button, if the multipath device is specified in CMS config file (for s390x arch), anaconda behaves as expected.

Version-Release number of selected component (if applicable):
RHEL6.0-20100722.0
anaconda-13.21.60-1.el6

How reproducible:
always

Steps to Reproduce:
1. run graphical installation
2. Select "Specialized Storage devices"
3. use "Add Advanced Target" button to add first path to a multipath device
3. use "Add Advanced Target" button again and add second path to the multipath device
  
Actual results:
"Other SAN Devices" tab shows:
 * multipath device
 * the first path of the multipath device

Expected results:
"Other SAN Devices" tab shows only the multipath device

Additional info:
see bug 597223
Comment 1 Jan Stodola 2010-07-27 04:31:19 EDT
Created attachment 434622 [details]
multipath zfcp added using "Add Advanced Target" button

This is when adding FCP LUNs via GUI. See the "Other SAN Devices" tab. There is
a multipath FCP LUN (60:05:...) and one single path FCP (ccw-0.0.a000-zfcp-...).
Device ccw-0.0.a000-zfcp... is the first path of the multipath LUN and should not be shown.
Comment 6 RHEL Product and Program Management 2011-06-14 15:09:50 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux maintenance release. Product Management has 
requested further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed 
products. This request is not yet committed for inclusion in an Update release.
Comment 7 David Cantrell 2011-07-25 15:32:25 EDT
Can you send me a tar.gz of /sys from a system this bug appears on?
Comment 8 David Cantrell 2011-07-29 11:40:35 EDT
Any updates?
Comment 9 Jan Stodola 2011-08-08 04:27:46 EDT
Created attachment 517129 [details]
sys.tar.gz

Sorry for the delay, I was on PTO.

Attaching gziped /sys directory
Build RHEL6.2-20110808.n.0 (anaconda-13.21.126-1.el6), still able to reproduce this bug.
Comment 10 David Cantrell 2011-08-08 11:51:45 EDT
Next questions:

1) You said if you specify the devices in the CMS conf file, everything works fine.  Can you provide an example conf file that works?

2) When you click Add Advanced, what values are you giving it and in what order?
Comment 13 David Cantrell 2011-08-15 16:10:04 EDT
I am unable to connect to FCP LUNS on any WWPN other than 500507630503c73d, so I can't easily recreate this issue.  Can I get access to one of your guests where you able to reproduce the problem so I can work up a fix?
Comment 17 Jan Stodola 2011-08-17 04:48:27 EDT
Created attachment 518615 [details]
DASD devices listed twice

David, with anaconda-13.21.129-1.el6 (build RHEL6.2-20110817.n.0) I'm not able to reproduce the original problem - so it is fixed.
But there is a new issue, most probably related to this fix - after adding both paths to the multipath FCP LUN, all DASD devices are added to the "Basic Devices" tab once more - it means all DASD devices are listed twice. See attached screenshots, anaconda logs will follows...
Comment 19 David Cantrell 2011-08-17 13:33:27 EDT
I see what's happening.  I just need to not invalidate the _cachedDevices list like I thought I did:

diff --git a/iw/filter_gui.py b/iw/filter_gui.py
index d6dac34..0c29c16 100644
--- a/iw/filter_gui.py
+++ b/iw/filter_gui.py
@@ -470,10 +470,9 @@ class FilterWindow(InstallWindow):
         for mp in new_mpaths:
             for d in mp:
                 # If any of the multipath components are in the nonraids cache,
-                # invalidate that cache and remove it from the UI store.
+                # remove them from the UI store.
                 if d in self._cachedDevices:
                     self.depopulate(d)
-                    del(self._cachedDevices[:])
 
                 # If all components of this multipath device are in the
                 # cache, skip it.  Otherwise, it's a new device and needs to
Comment 21 Jan Stodola 2011-08-25 04:36:04 EDT
Tested on build RHEL6.2-20110823.1 with anaconda-13.21.134-1.el6.

There was only one multipath device visible after manually adding all path for FCP LUN. The same result when the multipath LUN was specified in CMS config file.
Issue from comment 17 is also fixed.

Moving to VERIFIED.
Comment 22 errata-xmlrpc 2011-12-06 05:26:46 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1565.html

Note You need to log in before you can comment on or make changes to this bug.