Bug 618558 - UDP checksum offload breaks DHCP on virtual machines
Summary: UDP checksum offload breaks DHCP on virtual machines
Status: CLOSED DUPLICATE of bug 605555
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 6.1
Hardware: All Linux
low
urgent
Target Milestone: rc
: ---
Assignee: Michael S. Tsirkin
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Keywords: Reopened, RHELNAK
Depends On:
Blocks: 580953
TreeView+ depends on / blocked
 
Reported: 2010-07-27 09:23 UTC by Neil Wilson
Modified: 2013-01-09 22:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-04 21:50:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 610391 None None None Never

Description Neil Wilson 2010-07-27 09:23:17 UTC
Description of problem:

While running an Ubuntu Lucid virtual server under kvm on RHEL6, the DHCP system reports 'bad udp checksum' in response to DHCP offer packets coming from the libvirt launched dnsmasq process on the Host. Comparing RHEL5 to RHEL6 show that tx checksumming is switched on across the 'vnet' interfaces. 


Version-Release number of selected component (if applicable):

kernel.x86_64 2.6.32-44.1.el6 @anaconda-RedHatEnterpriseLinux6-201004141252.x86_64/6.0

How reproducible:

Setup a virtual network handing out DHCP addresses and run a virtual machine running dhclient3. If you run the dhclient3 in the console, you will see 'bad udp checksum in 5 packets' errors. tcpdump shows that the DHCP offer packet are reaching the virtual machine.

Steps to Reproduce:
1.
2.
3.
  
Actual results:

'bad udp checksum in 5 packets'

Expected results:

virtual machine picks up the ip address as normal.


Additional info:

http://www.pubbs.net/201004/dhcp/30492-dhcpd-problem-on-virtual-machines.html

Comment 2 Neil Wilson 2010-07-27 09:56:41 UTC
Ubuntu bug:

https://bugs.edge.launchpad.net/linux/+bug/610391

Comment 3 RHEL Product and Program Management 2010-07-27 09:58:06 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 4 Dor Laor 2010-07-28 12:53:58 UTC
We solved that using netfilter, Michael ,please find the bug number to point to and close this bug

Comment 5 Michael S. Tsirkin 2010-07-28 13:55:57 UTC

*** This bug has been marked as a duplicate of bug 605555 ***

Comment 6 Neil Wilson 2010-07-28 14:39:03 UTC
I can't see that bug. What is the fix?

Comment 7 Neil Wilson 2010-07-29 10:31:47 UTC
Verified the bug with libvirt-0.8.1-15.el6.x86_64, kernel-2.6.32-52.el6.x86_64 and iptables-1.4.7-3.el6.x86_64, and PASSED

Comment 8 Michael S. Tsirkin 2010-08-03 14:56:27 UTC
Change to verified?

Comment 9 Dor Laor 2010-08-04 21:50:39 UTC

*** This bug has been marked as a duplicate of bug 605555 ***


Note You need to log in before you can comment on or make changes to this bug.