Bug 618561 - completed job is shown 50% in progress
Summary: completed job is shown 50% in progress
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: beah (Show other bugs)
(Show other bugs)
Version: 0.5
Hardware: All Linux
low
medium vote
Target Milestone: ---
Assignee: Marian Csontos
QA Contact:
URL:
Whiteboard:
Keywords:
: 627870 (view as bug list)
Depends On:
Blocks: 621843
TreeView+ depends on / blocked
 
Reported: 2010-07-27 09:32 UTC by Han Pingtian
Modified: 2011-09-28 15:34 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 621843 (view as bug list)
Environment:
Last Closed: 2010-09-02 05:39:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Han Pingtian 2010-07-27 09:32:55 UTC
Description of problem:
I have a job which should be finished, but web ui shows it is 50% in progress:

https://beaker.engineering.redhat.com/jobs/8555

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Marian Csontos 2010-07-27 11:54:35 UTC
I have seen it before: this happens when there is no result in a task.

It is questionable whether this should be considered a bug in the task or in the scheduler - in any case it would need documenting.

The options are:

Unless the test returns a result it does not fail nor succeed. Fix the test.
Unless the test fails explicitly it should be considered Pass.

Each approach has its Pros and Cons...

Comment 2 Han Pingtian 2010-08-05 04:04:47 UTC
There is reserving job which I returned the machines by 'return2beaker', but it shows 75% in running state, though all recipes are finished.

https://beaker.engineering.redhat.com/jobs/10373

Comment 3 Marian Csontos 2010-08-06 09:21:07 UTC
Han, I think what you see now is different issue and this time something is wrong indeed. I am cloning the bug.

Comment 4 Marian Csontos 2010-08-06 14:59:28 UTC
Taking this: harness should handle it, when there is no result.

Comment 5 Marian Csontos 2010-08-27 08:54:26 UTC
*** Bug 627870 has been marked as a duplicate of this bug. ***

Comment 6 Marian Csontos 2010-08-31 12:03:14 UTC
Fix tested in a VM. Brewing RPMs to test on stage.


Note You need to log in before you can comment on or make changes to this bug.