Bug 61859 - RFE: Handle firewall settings and selected services so they don't conflict on ports
RFE: Handle firewall settings and selected services so they don't conflict on...
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-25 06:14 EST by Telsa Gwynne
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-16 14:56:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Telsa Gwynne 2002-03-25 06:14:35 EST
Description of Problem:

Anaconda happily let me choose both NIS for passwords and a medium firewall
without any warning that this combination won't let me login.

Version-Release number of selected component (if applicable): skipjack's anaconda

How Reproducible: will try on another box and find out. So far, one out of one.


Steps to Reproduce:
1. Install skipjack
2. Select NIS in passwords
3. Create root account: leave rest for NIS to find.
3. Select medium firewall

Actual Results:

Can login as root but not as users.

Expected Results:

Can login as all users.

Additional Information:
	
This is the first time I have touched NIS. This may be pilot error :)
Comment 1 Michael Fulbright 2002-03-25 14:54:22 EST
lokkit doesn't really do anything that sophicated (all anaconda does is call the
lokkit program with command line args based on the 'level of security' you selected.

The documentation for that screen tries to explain the possible interactions
between the firewall setting and services, but it is not intended to be a
substitute for a true services/firewall config tool (which doesn't exist).

Something we can revisit in the future once the OS has a tool to do this better
than lokkit.
Comment 2 Michael Fulbright 2003-04-16 14:56:13 EDT
This is not a feature we are going to add to the installer.

Note You need to log in before you can comment on or make changes to this bug.