Bug 618603 - high scores lost on upgrade
Summary: high scores lost on upgrade
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gweled (Show other bugs)
(Show other bugs)
Version: 15
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-27 11:08 UTC by Edward Sheldrake
Modified: 2011-03-16 04:03 UTC (History)
1 user (show)

Fixed In Version: gweled-0.9-3.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-16 04:03:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Edward Sheldrake 2010-07-27 11:08:29 UTC
Description of problem:
gweled high scores are lost on rpm upgrades.

Version-Release number of selected component (if applicable):
gweled-0.7-17.1

How reproducible:
Always, when the package gets updated.

Steps to Reproduce:
1. install Fedora 12 version of gweled
2. play and finish a game
3. update to Fedora 13 version
  
Actual results:
High scores disappear.

Expected results:
High scores are saved.

Additional info:
The high score files should be marked %config(noreplace) in gweled.spec.

I actually noticed this when building myself a rpm of gweled 0.8 from https://launchpad.net/gweled

Comment 1 Fedora Admin XMLRPC Client 2010-12-14 13:54:19 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 2 Edward Sheldrake 2011-03-10 10:03:53 UTC
Looks like gweled 0.9-2.fc15 is still lacking %config(noreplace) on the high score files.

Comment 3 Fedora Update System 2011-03-11 14:03:15 UTC
gweled-0.9-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gweled-0.9-2.fc15

Comment 4 Fedora Update System 2011-03-11 14:05:49 UTC
gweled-0.9-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gweled-0.9-3.fc15

Comment 5 Fedora Update System 2011-03-16 04:03:24 UTC
gweled-0.9-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.