Bug 618633 - new service UI should not allow resource editing
new service UI should not allow resource editing
Status: CLOSED DUPLICATE of bug 600027
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: luci (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Ryan McCabe
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-27 08:24 EDT by Fabio Massimo Di Nitto
Modified: 2010-07-27 18:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-27 18:52:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabio Massimo Di Nitto 2010-07-27 08:24:33 EDT
testing new the service UI from git:

create something like this (either via UI or manually)

                <resources>
                        <clusterfs device="/dev/vdb2" force_unmount="on" fsid="30538" fstype="gfs2" mountpoint="/mnt" name="gfs2-test"/>
                        <ip address="192.168.3.1" monitor_link="on"/>
                        <ip address="2001:41a8:5::dead/64" monitor_link="on"/>
                        <ip address="192.168.3.2" monitor_link="on"/>
                        <ip address="192.168.3.3" monitor_link="on"/>
                        <ip address="192.168.3.4" monitor_link="on"/>
                        <ip address="192.168.3.5" monitor_link="on"/>
                </resources>
                <service autostart="1" domain="test" exclusive="0" name="sss" recovery="relocate">
                        <ip ref="192.168.3.1">
                                <ip ref="192.168.3.2">
                                        <ip ref="192.168.3.3">
                                                <ip ref="192.168.3.4">
                                                        <ip ref="192.168.3.5">
                                                                <ip ref="2001:41a8:5::dead/64">
                                                                        <clusterfs ref="gfs2-test"/>
                                                                </ip>
                                                        </ip>
                                                </ip>
                                        </ip>
                                </ip>
                        </ip>
                </service>

Display the service in the UI, then go to 192.168.3.5 (for example) and change the IP address to 192.168.3.6, Submit -> KABOOM

12:56:31,070 ERROR [luci.widget_validators.validate_resource] Error validating ip resource
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/luci/widget_validators/validate_resource.py", line 528, in validate_clusvc_form
    newRes = model.getResourceByName(dummy_form['resourcename'])
  File "/usr/lib/python2.6/site-packages/luci/lib/ClusterConf/ModelBuilder.py", line 870, in getResourceByName
    raise KeyError, name
KeyError: '192.168.3.6'

In my opinion the service UI should NOT allow to edit resources.
Comment 1 Ryan McCabe 2010-07-27 18:52:06 EDT

*** This bug has been marked as a duplicate of bug 600027 ***

Note You need to log in before you can comment on or make changes to this bug.