Bug 618637 - gdb crashed when I tried to set breakpoint
Summary: gdb crashed when I tried to set breakpoint
Status: CLOSED DUPLICATE of bug 612253
Alias: None
Product: Fedora
Classification: Fedora
Component: gdb   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jan Kratochvil
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-27 12:43 UTC by Martin Stransky
Modified: 2010-07-27 22:26 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-27 22:26:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Martin Stransky 2010-07-27 12:43:57 UTC
Description of problem:

gdb crashed when I tried to set breakpoint,
core file - http://people.redhat.com/stransky/gdb/core.27654.tar.bz

Version-Release number of selected component (if applicable):
gdb-7.1.90.20100721-5.fc14.i686

How reproducible:
Always

Steps to Reproduce:
1. build spice-xpi plugin, install it to firefox
2. firefox -g -d gdb
3. (gdb) r
4. CTRL+C
5. (gdb) b SpiceController::Connect
6. crash
  
Additional info:
I debugged a working version of firefox-4beta2 so it may not be reproducible with our stock firefox.

Comment 1 Martin Stransky 2010-07-27 12:44:46 UTC
note: (gdb) b controller.cpp:50 (the same place) works as expected.

Comment 2 Jan Kratochvil 2010-07-27 13:24:22 UTC
That core file is not readable.

$ file core.27654.tar.bz 
core.27654.tar.bz: data
$ gzip <core.27654.tar.bz |wc -c
53319
$ od -c core.27654.tar.bz |head -n3
0000000  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0
*
140400000 207 215 371 347   _ 371 233 246 327 211   k 316 201   K 226 214

OTOH I have some similar Bug on internal error on placing a breakpoint, I cannot find it now.

Comment 3 Martin Stransky 2010-07-27 13:31:59 UTC
ahh, sory, it's not gzip but b2zip.

Comment 4 Jan Kratochvil 2010-07-27 13:36:18 UTC
No package /usr/bin/b2zip available.

.bz should be bzip but it is not bzip (and I cannot find bzip in Fedora repo).

Any compression program cannot produce 25MB file mostly full of zeroes. :-)

Comment 5 Martin Stransky 2010-07-27 13:45:06 UTC
Hm, it looks like it was cut by quota at people.redhat.com. Unfortunately I don't have a backup copy. Will try to produce another one.

Comment 6 Martin Stransky 2010-07-27 13:47:48 UTC
(gdb) b SpiceController::Connect
../../gdb/breakpoint.c:7295: internal-error: expand_line_sal_maybe: Assertion `found' failed.
A problem internal to GDB has been detected,
further debugging may prove unreliable.
Quit this debugging session? (y or n) n

../../gdb/breakpoint.c:7295: internal-error: expand_line_sal_maybe: Assertion `found' failed.
A problem internal to GDB has been detected,
further debugging may prove unreliable.
Create a core file of GDB? (y or n) y

Comment 7 Jan Kratochvil 2010-07-27 22:26:36 UTC

*** This bug has been marked as a duplicate of bug 612253 ***


Note You need to log in before you can comment on or make changes to this bug.