Bug 618658 - Tried to do a yum update -y
Tried to do a yum update -y
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum (Show other bugs)
All Linux
low Severity medium
: rc
: ---
Assigned To: packaging-team-maint
BaseOS QE Security Team
Depends On:
  Show dependency treegraph
Reported: 2010-07-27 09:41 EDT by Bob Full
Modified: 2014-01-21 01:18 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-03-12 16:50:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bob Full 2010-07-27 09:41:44 EDT
Description of problem:
Told to report bug

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info: Output:
yum update -y
Loaded plugins: rhnplugin, security
rhel-i386-server-5                                       | 1.3 kB     00:00
rhel-i386-server-5/primary                               | 2.9 MB     00:05
rhel-i386-server-5                                                    7374/7374
Skipping security plugin, no data
Setting up Update Process
Resolving Dependencies
Skipping security plugin, no data
--> Running transaction check
---> Package glibc.i686 0:2.5-49.el5_5.4 set to be updated
--> Processing Dependency: glibc-common = 2.5-49.el5_5.4 for package: glibc
---> Package glibc-devel.i386 0:2.5-49.el5_5.4 set to be updated
--> Processing Dependency: glibc-headers = 2.5-49.el5_5.4 for package: glibc-devel
--> Running transaction check
---> Package glibc-common.i386 0:2.5-49.el5_5.4 set to be updated
---> Package glibc-headers.i386 0:2.5-49.el5_5.4 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

 Package            Arch      Version             Repository               Size
 glibc              i686      2.5-49.el5_5.4      rhel-i386-server-5      5.3 M
 glibc-devel        i386      2.5-49.el5_5.4      rhel-i386-server-5      2.0 M
Installing for dependencies:
 glibc-common       i386      2.5-49.el5_5.4      rhel-i386-server-5       16 M
 glibc-headers      i386      2.5-49.el5_5.4      rhel-i386-server-5      602 k

Transaction Summary
Install       2 Package(s)
Upgrade       2 Package(s)

Total download size: 24 M
Downloading Packages:
(1/4): glibc-headers-2.5-49.el5_5.4.i386.rpm             | 602 kB     00:01
(2/4): glibc-devel-2.5-49.el5_5.4.i386.rpm               | 2.0 MB     00:01
(3/4): glibc-2.5-49.el5_5.4.i686.rpm                     | 5.3 MB     00:04
(4/4): glibc-common-2.5-49.el5_5.4.i386.rpm              |  16 MB     00:11
Total                                           1.2 MB/s |  24 MB     00:20
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
glibc-headers is needed by (installed) glibc-devel-2.5-49.el5_5.2.x86_64
glibc-headers is needed by (installed) glibc-devel-2.5-49.el5_5.2.x86_64
(1, [u'Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Linux%205&component=yum'])
Comment 1 seth vidal 2010-07-27 09:50:14 EDT
Is this an x86_64 or i686 machine?

can you run:
uname -a

and rpm -q rpm


Note You need to log in before you can comment on or make changes to this bug.