Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 618661 - libvirtd fails to insert needed iptables rules for NAT network due to missing CHECKSUM module
libvirtd fails to insert needed iptables rules for NAT network due to missing...
Status: CLOSED DUPLICATE of bug 612587
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: iptables (Show other bugs)
6.0
All Linux
low Severity high
: rc
: ---
Assigned To: iptables-maint-list
qe-baseos-daemons
: RHELNAK
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-27 09:52 EDT by Mauricio Teixeira
Modified: 2010-08-05 15:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-27 11:44:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mauricio Teixeira 2010-07-27 09:52:38 EDT
Description of problem:

libvirtd fails to insert needed iptables rules for NAT network due to missing CHECKSUM module, which prevents DHCP from working on virtual network interfaces.

Version-Release number of selected component (if applicable):

libvirt-0.8.1-15.el6.x86_64
iptables-1.4.7-2.el6.x86_64

How reproducible:

Always.

Steps to Reproduce:
1. service libvirtd restart
2. (watch /var/log/messages)

Actual results:

libvirtd: 10:42:46.110: error : virRunWithHook:933 : internal error '/sbin/iptables --table mangle --insert POSTROUTING --out-interface virbr0 --protocol udp --destination-port 68 --jump CHECKSUM --checksum-fill' exited with non-zero status 2 and signal 0: iptables v1.4.7: unknown option `--checksum-fill'#012Try `iptables -h' or 'iptables --help' for more information.#012
libvirtd: 10:42:46.110: warning : networkAddIptablesRules:851 : Could not add rule to fixup DHCP response checksums on network 'default'

Expected results:

Should not give error.

Additional info:

# /sbin/iptables --table mangle --insert POSTROUTING --out-interface virbr0 --protocol udp --destination-port 68 --jump CHECKSUM
iptables v1.4.7: Couldn't load target `CHECKSUM':/lib64/xtables/libipt_CHECKSUM.so: cannot open shared object file: No such file or directory
# rpm -V iptables
(nothing)
Comment 2 RHEL Product and Program Management 2010-07-27 10:18:11 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 3 Phil Knirsch 2010-07-27 10:43:11 EDT
What kernel version please?

Thanks & regards, Phil
Comment 4 Mauricio Teixeira 2010-07-27 11:00:31 EDT
2.6.32-52.el6.x86_64

Note You need to log in before you can comment on or make changes to this bug.