Bug 618738 - Kaffeine play video files, audio work but the video isn't displayed.
Kaffeine play video files, audio work but the video isn't displayed.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kaffeine (Show other bugs)
14
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Thomas Janssen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: qt47
  Show dependency treegraph
 
Reported: 2010-07-27 11:51 EDT by Carl G.
Modified: 2010-09-23 08:40 EDT (History)
5 users (show)

See Also:
Fixed In Version: kaffeine-1.1-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-20 21:36:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 241553 None None None Never

  None (edit)
Description Carl G. 2010-07-27 11:51:45 EDT
Version-Release number of selected component (if applicable):

KDE SC 4.4.95
kaffeine-1.0-5.fc14.x86_64

How reproducible:

Always.
  
Actual results:

The video start playing, as expected, with sound but nothing is being displayed.

Expected results:

Being able to watch funny cats videos? :P Nah..

Additional info:

I noticed this issue appeared after upgrading from RC2 to RC3.
Comment 1 Rex Dieter 2010-07-27 11:54:45 EDT
I saw this too, after up'ing from 4.4.5 -> 4.4.92 on f13 using kde-unstable repos, go figure.
Comment 2 Carl G. 2010-07-27 11:56:39 EDT
Just to make it clear, it really seems to be an issue w. Kaffeine, i can play videos in ANY player that use the xine backend, well, almost :)
Comment 3 Bug Zapper 2010-07-30 08:54:05 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Frank Thieme 2010-08-19 02:56:10 EDT
(In reply to comment #1)
> I saw this too, after up'ing from 4.4.5 -> 4.4.92 on f13 using kde-unstable
> repos, go figure.

Just tested with kaffeine-1.0-3.fc13.x86_64 on SC 4.5.0 on f13: worked as it should.
Comment 5 Thomas Janssen 2010-08-19 03:54:58 EDT
(In reply to comment #4)
> (In reply to comment #1)
> > I saw this too, after up'ing from 4.4.5 -> 4.4.92 on f13 using kde-unstable
> > repos, go figure.
> 
> Just tested with kaffeine-1.0-3.fc13.x86_64 on SC 4.5.0 on f13: worked as it
> should.

Not yet fixed. Guess you were just lucky. I just tested it with 4.5.0, Qt-4.7.0.beta, kaffeine-1.0-3.fc13.x86_64 (my primary system) and all the latest updates from updates-testing/kde-unstable/kde-testing. Nothing changed.

Though, it would be interesting if your system is fresh installed?
Comment 6 Thomas Janssen 2010-08-19 04:02:47 EDT
https://bugs.kde.org/show_bug.cgi?id=241553

Related upstream bug.
Comment 7 Frank Thieme 2010-08-19 04:48:26 EDT
(In reply to comment #5)
> Not yet fixed. Guess you were just lucky. I just tested it with 4.5.0,
> Qt-4.7.0.beta, kaffeine-1.0-3.fc13.x86_64 (my primary system) and all the
> latest updates from updates-testing/kde-unstable/kde-testing. Nothing changed.
> 
> Though, it would be interesting if your system is fresh installed?

Not that fresh installed. I guess I never used kaffeine before. Now as I retest it, it clearly shows the problem...
Comment 8 Thomas Janssen 2010-08-19 05:35:09 EDT
Ok, thanks for the report. I tried to remove (renamed) all the kaffeine related stuff in .kde/share/apps .kde/share/config .kde-save/share/apps .kde-save/share/config but the problem was still there.

I will try to dig deeper into it with a bit more time.
Comment 9 Rex Dieter 2010-08-26 16:21:34 EDT
This seems specific to qt-4.7, not kde-4.5 (I recently reverted my f13 back to qt-4.6.3 and this problem went away).
Comment 10 Fedora Update System 2010-09-06 16:57:41 EDT
kaffeine-1.1-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/kaffeine-1.1-1.fc14
Comment 11 Fedora Update System 2010-09-06 16:57:51 EDT
kaffeine-1.1-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/kaffeine-1.1-1.fc13
Comment 12 Fedora Update System 2010-09-07 02:45:40 EDT
kaffeine-1.1-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kaffeine'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/kaffeine-1.1-1.fc14
Comment 13 Fedora Update System 2010-09-20 21:36:06 EDT
kaffeine-1.1-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2010-09-23 08:39:53 EDT
kaffeine-1.1-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.