Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 618779 - Need avogadro 1.0.1 for kdeedu 4.5
Need avogadro 1.0.1 for kdeedu 4.5
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: avogadro (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
:
Depends On:
Blocks: kde-4.5
  Show dependency treegraph
 
Reported: 2010-07-27 13:36 EDT by Kevin Kofler
Modified: 2010-08-24 23:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-24 23:01:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Kofler 2010-07-27 13:36:16 EDT
Description of problem:
We need avogadro upgraded to 1.0.1 in F12 and F13 to build Kalzium's libavogadro support. (Previously, Kalzium bundled its own snapshots of libavogadro because there was no fixed API/ABI, now there finally is.) 1.0.0 is too old.

We also need to reenable the avogadro-devel BR in Rawhide's kdeedu. Rawhide already has 1.0.1, but the BR got disabled. The avogadro package seems to need adjustments to allow reusing libavogadro for Kalzium.

Version-Release number of selected component (if applicable):
avogadro-1.0.1-2.fc14 (needs adjustments)
avogadro-1.0.0-* (too old)

How reproducible:
Always.

Steps to Reproduce:
1. Try to build kdeedu 4.5 or trunk (4.6).

Actual results:
kdeedu refuses to build libavogadro support into Kalzium because libavogadro is too old.

Expected results:
libavogadro 1.0.1 available.

Additional info:
See: http://websvn.kde.org/?view=revision&revision=1113462

We may also want to backport this to our 4.4.5 packaging because the bundled library is technically violating a packaging guideline. But 4.5 is coming soon anyway…
Comment 1 Bug Zapper 2010-07-30 08:54:17 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Kevin Kofler 2010-08-24 23:01:58 EDT
I'll close this because the new avogadro is now in Rawhide, there are also builds for F13 and F14, we just need to make sure we push this to F13 and possibly F12 together with KDE 4.5. F14 already has 1.0.1, but with issues preventing a successful build of kdeedu against it; I'm queueing a fixed avogadro together with kdeedu as a F14 update.

Note You need to log in before you can comment on or make changes to this bug.