Bug 618791 - totem does not build against libpeas-devel-0.5.3-2.fc14: missing symbols: peas_plugin_info_{s|g}et_visible
totem does not build against libpeas-devel-0.5.3-2.fc14: missing symbols: pea...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
14
All Linux
low Severity urgent
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F14Alpha/F14AlphaBlocker Python27Rebuild
  Show dependency treegraph
 
Reported: 2010-07-27 14:12 EDT by Dave Malcolm
Modified: 2010-08-01 15:21 EDT (History)
2 users (show)

See Also:
Fixed In Version: totem-2.90.5-5.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-01 15:21:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for remaining problems in totem build (1.78 KB, text/plain)
2010-07-28 12:55 EDT, Adam Williamson
no flags Details

  None (edit)
Description Dave Malcolm 2010-07-27 14:12:07 EDT
Description of problem:
totem-2.90.5-2.fc14 fails to build against  libpeas-devel-0.5.3-2.fc14:
plugins/totem-plugins-engine.c: In function 'plugin_is_builtin':
plugins/totem-plugins-engine.c:105:3: warning: implicit declaration of function 'peas_plugin_info_set_visible'
plugins/totem-plugins-engine.c:105:3: warning: nested extern declaration of 'peas_plugin_info_set_visible'
plugins/totem-plugins-engine.c: In function 'on_activatable_extension_added':
plugins/totem-plugins-engine.c:169:3: warning: implicit declaration of function 'peas_plugin_info_get_visible'
plugins/totem-plugins-engine.c:169:3: warning: nested extern declaration of 'peas_plugin_info_get_visible'

and later fails with linker errors:
./.libs/libtotem.so: undefined reference to `peas_plugin_info_set_visible'
./.libs/libtotem.so: undefined reference to `peas_plugin_info_get_visible'
Comment 1 Dave Malcolm 2010-07-27 14:14:29 EDT
Seems to be this upstream commit:
http://git.gnome.org/browse/libpeas/commit/?id=7d4e464c00168caa4893185a12e45af1b80c99a2
Comment 2 Dave Malcolm 2010-07-27 14:24:03 EDT
Looks like we need to cherrypick http://git.gnome.org/browse/totem/commit/?id=c73bd203eed8b8d1cb45f8746a988d8cda0d408d ; trying that now
Comment 3 Adam Williamson 2010-07-28 12:54:55 EDT
here's a cvs diff for the rest of the fix for totem to build in rawhide (looks like this new version adds a shared library and some gir stuff).



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Adam Williamson 2010-07-28 12:55:35 EDT
Created attachment 435076 [details]
patch for remaining problems in totem build
Comment 5 Bug Zapper 2010-07-30 08:54:23 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Adam Williamson 2010-07-30 12:48:58 EDT
This is blocking F14 Alpha, as Totem having dependencies issues would break the live and DVD composes. We need the patch applied and a rebuild done by Tuesday to avoid delaying the Alpha.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Fedora Update System 2010-07-30 15:42:46 EDT
totem-2.90.5-5.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/totem-2.90.5-5.fc14
Comment 8 Dave Malcolm 2010-07-30 15:44:22 EDT
Also build as totem-2.90.5-5.fc15 into master
Comment 9 Fedora Update System 2010-08-01 15:21:03 EDT
totem-2.90.5-5.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.