Bug 61885 - scanner isn't recognized anymore
Summary: scanner isn't recognized anymore
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: sane-backends (Show other bugs)
(Show other bugs)
Version: skipjack-beta1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 61901
TreeView+ depends on / blocked
 
Reported: 2002-03-25 16:32 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-03 14:41:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-03-25 16:32:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020314

Description of problem:
I used sane-1.0.6-3.rpm My Mustek 1200CU worked very fine.
Now, after I ugraded to skipjack with sane-1.0.7.x.rpm my scanner isn't
recoginized anymore

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Rebuild the kernel with usb-scanner-support. (Not as module.)
2.I downgraded to sane-1.0.6-3.rpm
3.
	

Actual Results:  sane-1.0.7 still doesn't work.
sane-1.0.6-3 works fine again.

Additional info:

Comment 1 Need Real Name 2002-04-02 14:02:12 UTC
This problem seems to be present with EPSON  PERFECTION 1640SU connected via USB
too.

Comment 2 Tim Waugh 2002-04-03 12:47:09 UTC
If you back off to the last known working kernel, does the problem still happen?
 In other words, is this a kernel problem or a sane problem?

Comment 3 Tim Waugh 2002-04-03 12:47:54 UTC
Never mind, I missed that 1.0.6-3 works for you.  Okay, SANE problem.

Comment 4 Tim Waugh 2002-04-03 12:51:54 UTC
Which front ends are you both using?  scanimage?  xscanimage?  xsane?

Does 'sane-find-scanner' show your scanners?

jscj@xs4all.nl: Please attach the output of:
  SANE_DEBUG_MUSTEK_USB=7 scanimage -L

knut@orion.no: Please attach the output of:
  SANE_DEBUG_EPSON=128 scanimage -L

Thanks.

Comment 5 Need Real Name 2002-04-03 14:41:47 UTC
I am using xsane but xscanimage and scanimage all fails
sane-find-scanner finds the scanner
sane-find-scanner: found USB scanner (vendor = 0x04b8, product = 0x010a) at
device /dev/usb/scanner0


[root@knut2 knut]# SANE_DEBUG_EPSON=128 scanimage -L

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).


Comment 6 Tim Waugh 2002-04-03 15:02:39 UTC
knut@orion.no: Please edit /etc/sane.d/epson.conf to put a line in like this:
  usb /dev/usb/scanner0

Does that fix the problem with the Epson scanner? (It can't be enabled like that
by default, unfortunately--see the comment in the configuration file about it.)

Comment 7 Need Real Name 2002-04-03 15:08:28 UTC
This was already done before my atempts

[knut@knut2 normal]$ cat /etc/sane.d/epson.conf
# epson.conf
#
# here are some examples for how to configure the EPSON backend
#
# SCSI scanner:
#scsi EPSON
#
# Parallel port scanner:
#pio 0x278
#pio 0x378
#pio 0x3BC
#
# USB scanner - only enable this if you have an EPSON scanner. It could
#               otherwise block your non-EPSON scanner from being 
#               recognized.
usb /dev/usb/scanner0


Comment 8 Need Real Name 2002-04-10 14:47:02 UTC
The problem is still present in beta2

Comment 9 Tim Waugh 2002-05-02 13:36:04 UTC
Do you have 'epson' listed in /etc/sane.d/dll.conf?  I can't understand why 
you wouldn't get any output from 'SANE_DEBUG_EPSON=128 scanimage -L'.  Can you 
try it again for me?

Comment 10 Need Real Name 2002-05-03 14:41:37 UTC
The bug went away after a complete upgrade using
RedHat Update Agent. (Including kernel upgrade).

One small buglet in the new epson.conf still exists. 
I had to change the line
usb /dev/usbscanner0
to
usb /dev/usb/scanner0
in /etc/sane.d/epson.conf after the upgrade.



Comment 11 Tim Waugh 2002-05-03 14:44:39 UTC
Okay.  The filename issue is already elsewhere in bugzilla. 



Note You need to log in before you can comment on or make changes to this bug.