Bug 618858 - move start-ds-admin env file into main admin server config path
Summary: move start-ds-admin env file into main admin server config path
Status: CLOSED CURRENTRELEASE
Alias: None
Product: 389
Classification: Retired
Component: Admin (Show other bugs)
(Show other bugs)
Version: 1.2.6
Hardware: All Other
low
medium
Target Milestone: ---
Assignee: Rich Megginson
QA Contact: Viktor Ashirov
URL:
Whiteboard:
Keywords: VerifiedUpstream
Depends On:
Blocks: 434915 389_1.2.7
TreeView+ depends on / blocked
 
Reported: 2010-07-27 21:31 UTC by Ulf Weltman
Modified: 2015-12-07 16:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 16:33:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch proposal (2.64 KB, patch)
2010-07-27 21:33 UTC, Ulf Weltman
nhosoi: review+
Details | Diff

Description Ulf Weltman 2010-07-27 21:31:02 UTC
To improve feng-shui on HP-UX we modify the layout by moving start-ds-admin's env file dirsrv-admin from /etc/opt/dirsrv-admin/config to /etc/opt/dirsrv/admin-serv.  (On HP-UX we keep files in /opt/dirsrv, /var/opt/dirsrv and /etc/opt/dirsrv.  That additional /etc/opt/dirsrv-admin path was awkward since it just contained the single env file.)

Comment 1 Ulf Weltman 2010-07-27 21:33:49 UTC
Created attachment 434864 [details]
patch proposal

I had to move the assignment of the instancename variable up in the file so it's available when the initconfigdir is set.

Comment 3 Noriko Hosoi 2011-02-04 21:43:02 UTC
Pushed to master on behalf of Ulf Weltman (ulf.weltman@hp.com):

$ git merge 618858
Updating fe73cc2..4aecc23
Fast-forward
 configure    |   11 +++++------
 configure.ac |   11 +++++------
 2 files changed, 10 insertions(+), 12 deletions(-)

$ git push
Counting objects: 7, done.
Delta compression using up to 4 threads.
Compressing objects: 100% (4/4), done.
Writing objects: 100% (4/4), 833 bytes, done.
Total 4 (delta 3), reused 0 (delta 0)
To ssh://git.fedorahosted.org/git/389/admin.git
   fe73cc2..4aecc23  master -> master

Comment 5 Noriko Hosoi 2011-07-20 21:07:41 UTC
Compared configure.ac in the git source tree with the one in the patch.
Verified that they are identical.

Note: the change only affects ia64-hp-hpux and hppa*-hp-hpux.

Comment 6 Rich Megginson 2011-07-25 18:27:39 UTC
Right.  This bug doesn't really apply to RHEL6 - you can just mark it as VerifiedUpstream


Note You need to log in before you can comment on or make changes to this bug.