Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 618859 - RFE: make whiteboards editable
RFE: make whiteboards editable
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
0.5
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: Dan Callaghan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-27 17:31 EDT by Marian Csontos
Modified: 2011-09-28 11:34 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-13 23:13:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch: make job whiteboard editable (7.72 KB, patch)
2010-08-20 00:50 EDT, Dan Callaghan
no flags Details | Diff

  None (edit)
Description Marian Csontos 2010-07-27 17:31:33 EDT
I know it is my fault, but when cloning recipes I am often forgetting to update recipe's whiteboard.
It's not very helpful comparing such jobs in matrix view without knowing what is a regression and what an improvement...
Comment 1 Dan Callaghan 2010-08-20 00:50:05 EDT
Created an attachment (id=439860)
Patch: make job whiteboard editable
Comment 2 Dan Callaghan 2010-08-20 00:53:04 EDT
The attached patch is my first go at implementing this. It seems to work nicely, although I'm not happy with how the UI looks (wasted too much time fiddling with it already though).

Might be possible to turn the new JobWhiteboard widget into some kind of generic "inline field with AJAXy submission" widget, if we have a need for it later.

I'll add a test case for editing the job whiteboard, as soon as I figure out how to do that.
Comment 3 Dan Callaghan 2010-09-26 23:06:51 EDT
Pushed branch bz618859 for review. I'd like to include this with 0.5.59. (I realise this is a low-priority RFE, but I've been sitting on a patch for this since my first week, and I figure it might as well get released.)

http://git.fedorahosted.org/git/?p=beaker.git;a=commitdiff;h=4c290f0c15988d1f9e1e90afcd62e0f73aefaaee

Note You need to log in before you can comment on or make changes to this bug.