Bug 618877 - Loading of apache configuration fails, when absolute path in "Include" directive is used.
Loading of apache configuration fails, when absolute path in "Include" direct...
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
3.0.0
All Linux
high Severity high (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Corey Welton
:
Depends On:
Blocks: jon30-bugs 656439
  Show dependency treegraph
 
Reported: 2010-07-27 18:57 EDT by Filip Drabek
Modified: 2011-05-23 21:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 656439 (view as bug list)
Environment:
Last Closed: 2011-05-23 21:07:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Filip Drabek 2010-07-27 18:57:28 EDT
Loading of apache configuration fails, when absolute path in "Include" directive is used and when the path contains regular expression like *.conf.

The error message is:

2010-07-28 00:45:27,917 ERROR [ResourceContainer.invoker.daemon-8] (org.rhq.plugins.apache.ApacheServerComponent)- Failed to load Apache configuration.
net.augeas.AugeasException: java.lang.IllegalStateException: Configuration files inclusion patterns refer to a non-existent file.
	at org.rhq.augeas.AugeasProxy.load(AugeasProxy.java:118)
	at org.rhq.plugins.apache.ApacheServerComponent.getAugeasProxy(ApacheServerComponent.java:362)
	at org.rhq.plugins.apache.ApacheServerComponent.getAugeasTree(ApacheServerComponent.java:367)
	at org.rhq.plugins.apache.ApacheServerComponent.loadResourceConfiguration(ApacheServerComponent.java:308)
	at sun.reflect.GeneratedMethodAccessor75.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at org.rhq.core.pc.inventory.ResourceContainer$ComponentInvocationThread.call(ResourceContainer.java:525)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
	at java.util.concurrent.FutureTask.run(FutureTask.java:138)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
	at java.lang.Thread.run(Thread.java:619)
Caused by: java.lang.IllegalStateException: Configuration files inclusion patterns refer to a non-existent file.
	at org.rhq.plugins.apache.augeas.AugeasConfigurationApache.loadFiles(AugeasConfigurationApache.java:174)
	at org.rhq.augeas.AugeasProxy.load(AugeasProxy.java:101)
	... 12 more
Comment 1 Filip Drabek 2010-08-05 07:57:40 EDT
fixed by commit 04f29c218de34e2b51686832366fb5be11a2415a
Comment 2 Sudhir D 2010-10-25 08:10:03 EDT
Verified this with the latest rhq-server-4.0.0-SNAPSHOT build# 446. 

I have the below in httpd.conf file, 

Include /etc/httpd/conf.d/*.conf

The apache configuration is getting loaded as expected. I do not see any exception in the log either. 

Marking this bug as verified.
Comment 3 Corey Welton 2011-05-23 21:07:17 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.