Bug 61890 - Segmentation fault (NOT hardware issue, savetemps attached)
Summary: Segmentation fault (NOT hardware issue, savetemps attached)
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-25 18:16 UTC by Need Real Name
Modified: 2007-04-18 16:41 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 19:47:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File created by gcc (with -save-temps) option (402.49 KB, text/plain)
2002-03-25 18:18 UTC, Need Real Name
no flags Details

Description Need Real Name 2002-03-25 18:16:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461)

Description of problem:
When compiling the kernel I get a "segmentation fault" very early during 
compilation and it's the exact same place each time, namely during processing 
of line 1161 of kernel/module.c

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. make bzImage
2. wait
3. error occurs
	

Actual Results:  The segementation I explaned above

Expected Results:  Successful compilation - I've compiled kernels many many 
times before

Additional info:

I've created a module.i file with error information. I just don't know where 
to submit it. (I just saw that attaching files is possible after submission - 
I will do this after submitting this report).

Comment 1 Need Real Name 2002-03-25 18:18:24 UTC
Created attachment 50224 [details]
File created by gcc (with -save-temps) option

Comment 2 Jakub Jelinek 2002-03-25 19:42:40 UTC
Please specify exact options you passed to gcc to reproduce this too.

Comment 3 Need Real Name 2002-03-28 14:21:40 UTC
The error occurs when compiling the kernel using the standard script (I simply 
typed "make bzImage"). When I produced the "module.i"-file, I copy & pasted 
the failing command line and added the "-save-temps" switch.
I'm starting to think that this is a problem with my system, because I get the 
same error when compiling the kernel in another linux distribution. But I 
wonder why the error occurs the exact same place everytime. I've tried 
memtest86 and it doesn't report an error.
A friend of mine says he has experienced this problem too but fixed it through 
BIOS tweaking. I will get back with more details as soon as I have them.


Note You need to log in before you can comment on or make changes to this bug.