This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 619001 - It sometimes takes 3 seconds to connect to a TCP server [rhel-6.0]
It sometimes takes 3 seconds to connect to a TCP server [rhel-6.0]
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Thomas Graf
Network QE
: RHELNAK, TestOnly
Depends On: 518651
Blocks: 645454 525215
  Show dependency treegraph
 
Reported: 2010-07-28 06:24 EDT by Eryu Guan
Modified: 2014-06-18 04:30 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 518651
Environment:
Last Closed: 2011-03-09 03:44:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 3 RHEL Product and Program Management 2010-07-28 06:57:55 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 22 Thomas Graf 2011-03-09 03:44:58 EST
The difference in behaviour of RHEL5 and RHEL6 was caused by commit:

commit 2bba22c50b06abe9fd0d23933b1e64d35b419262
Author: Mike Galbraith <efault@gmx.de>
Date:   Wed Sep 9 15:41:37 2009 +0200

    sched: Turn off child_runs_first

    Set child_runs_first default to off.

    It hurts 'optimal' make -j<NR_CPUS> workloads as make jobs
    get preempted by child tasks, reducing parallelism.
    [...]

With child_runs_first it takes longer for the backlog of the listening socket to fill.

Still, this is an application bug. The reason for some packets being dropped is that the backlog limit is reached. Applications increasing their backlog limit from the traditional limit of 128 to something that fits modern architectures will no longer be affected by this issue.

Note You need to log in before you can comment on or make changes to this bug.