Bug 619014 - SWnightly (from 2010-07-27) produces a lot of AVCs when restarting on F13
Summary: SWnightly (from 2010-07-27) produces a lot of AVCs when restarting on F13
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
(Show other bugs)
Version: 1.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jan Pazdziora
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Keywords:
: 630833 636365 (view as bug list)
Depends On:
Blocks: space12
TreeView+ depends on / blocked
 
Reported: 2010-07-28 11:18 UTC by Jan Hutař
Modified: 2010-11-19 16:16 UTC (History)
6 users (show)

Fixed In Version: spacewalk-monitoring-selinux-1.2.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-19 16:16:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Comment 1 Jan Hutař 2010-07-29 09:46:09 UTC
Hello,
using:

# rpm -qa | grep -i selinux | sort
libselinux-2.0.90-5.fc13.x86_64
libselinux-devel-2.0.90-5.fc13.x86_64
libselinux-python-2.0.90-5.fc13.x86_64
libselinux-utils-2.0.90-5.fc13.x86_64
oracle-instantclient-selinux-10.2-18.fc13.noarch
oracle-instantclient-sqlplus-selinux-10.2-18.fc13.noarch
oracle-nofcontext-selinux-0.1-23.15.fc13.noarch
oracle-xe-selinux-10.2-17.fc13.noarch
osa-dispatcher-selinux-5.9.37-1.fc13.noarch
selinux-policy-3.7.19-39.fc13.noarch
selinux-policy-targeted-3.7.19-39.fc13.noarch
spacewalk-monitoring-selinux-1.1.1-1.fc13.noarch
spacewalk-selinux-1.1.1-1.fc13.noarch
# rpm -qa | grep schema
spacewalk-schema-1.1.21-1.fc13.noarch
# rpm -q fedora-release
fedora-release-13-1.noarch

this really looks like restart is causing this:

# cat /var/log/audit/audit.log | audit2allow 
# rhn-satellite restart
[...]
# cat /var/log/audit/audit.log | audit2allow 


#============= spacewalk_monitoring_t ==============
allow spacewalk_monitoring_t usr_t:file open;

Comment 9 Jan Pazdziora 2010-10-04 15:53:21 UTC
Taking.

Comment 10 Jan Pazdziora 2010-10-04 16:20:31 UTC
Fixed in Spacewalk master, 257376e6b9a18ac17ac25f2249e95e4c3fa786f0.

Tagged ad built as spacewalk-monitoring-selinux-1.2.1-1.

Comment 11 Jan Pazdziora 2010-10-04 16:26:39 UTC
*** Bug 630833 has been marked as a duplicate of this bug. ***

Comment 12 Jan Pazdziora 2010-10-27 13:12:56 UTC
*** Bug 636365 has been marked as a duplicate of this bug. ***

Comment 15 Jan Pazdziora 2010-11-19 16:16:29 UTC
With Spacewalk 1.2 released, marking as CLOSED CURRENTRELEASE.

https://www.redhat.com/archives/spacewalk-list/2010-November/msg00111.html


Note You need to log in before you can comment on or make changes to this bug.