Bug 619049 - New jna 3.2.7 don't provides jna-examples = RQ & BR for intellij-idea
Summary: New jna 3.2.7 don't provides jna-examples = RQ & BR for intellij-idea
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: intellij-idea
Version: 13
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-28 12:58 UTC by Anton Guda
Modified: 2010-10-12 11:44 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-10-02 12:25:30 UTC
Type: ---


Attachments (Terms of Use)
patch (1.55 KB, patch)
2010-09-08 17:17 UTC, Levente Farkas
no flags Details | Diff

Description Anton Guda 2010-07-28 12:58:14 UTC
Description of problem:
New jna 3.2.7 from rawhile don't provides (and obsoletes)
jna-examples, which is requirement and BR for intellij-idea.
If this req removed from  intellij-idea spec file, build failed.

Version-Release number of selected component (if applicable):
jna-3.2.7-3.fc14.src.rpm
intellij-idea-9.0.1.94.399-11.fc14.src.rpm

How reproducible:
Always


Steps to Reproduce:
1. install new jna
2. try to build intellij-idea
3. try to build intellij-idea with removed req and BR
  
Actual results:
2: fail(BR)
3: fail:
+ cd ..
+ sh disablemodules.sh
+ sh replacedeps.sh
/usr/bin/build-classpath: error: Could not find jna-examples Java extension for this JVM
/usr/bin/build-classpath: error: Some specified jars were not found

Expected results:
intellij-idea build w/o errors


Additional info:

Comment 1 Levente Farkas 2010-07-28 13:24:38 UTC
because upstream does not provide it any more, but provide jna-contrib. that's why jna-contrib obsoletes jna-examples.
but i update jna to compile contrib packages too. and should have to update intellij-idea to use contrib's jars.

Comment 2 Levente Farkas 2010-08-14 13:39:43 UTC
there is a new build at:
http://koji.fedoraproject.org/koji/buildinfo?buildID=188927
unfortunately i can't build on other branches since this new fedpkg is still not working for me (see #619935) :-(

imho this problem should have to fix in intellij-idea to require jna-contrib and use the right jar.

Comment 3 Aaron Faanes 2010-08-20 19:22:44 UTC
Just noting that this problem has spread to updates-testing, so it's not just in rawhide anymore.

Comment 4 Hal Duston 2010-09-04 16:07:49 UTC
Just noting that this problem has now spread to updates, so it's not just in rawhide and updates-testing anymore.

Comment 5 Amir Hedayaty 2010-09-08 05:46:08 UTC
I guess you guys are on it. Anyway here is my report on FC13

----------------------------------------------------------------------------------
Resolving Dependencies
--> Running transaction check
---> Package jna.x86_64 0:3.2.7-5.fc13 set to be updated
---> Package jna-contrib.x86_64 0:3.2.7-5.fc13 set to be installed
--> Processing Dependency: jna-examples for package: intellij-idea-9.0.1.94.399-10.fc13.x86_64
--> Finished Dependency Resolution
Error: Package: intellij-idea-9.0.1.94.399-10.fc13.x86_64 (@fedora)
           Requires: jna-examples
           Removing: jna-examples-3.2.4-3.fc13.x86_64 (@fedora)
               jna-examples = 3.2.4-3.fc13
           Obsoleted By: jna-contrib-3.2.7-5.fc13.x86_64 (updates)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
----------------------------------------------------------------------------------

I do not know what will happen to intelij but can you just change the dependencies until the stable fix comes out?

Comment 6 Levente Farkas 2010-09-08 17:17:52 UTC
Created attachment 446047 [details]
patch

as it seems the maintainer not really responsive i attach a patch.
at the same time it'd be useful to update to the latest version.

Comment 7 Anton Guda 2010-10-02 12:20:13 UTC
Seems to be fixed in intellij-idea-9.0.1.94.399-12 (rawhide).
I propose to close this bug.

Comment 8 Piscium 2010-10-02 13:27:47 UTC
I have not checked rawhide, but this issue still very much exists in F13. Just tried it now:

----------------
Resolving Dependencies
--> Running transaction check
---> Package jna.i686 0:3.2.7-5.fc13 set to be updated
---> Package jna-contrib.i686 0:3.2.7-5.fc13 set to be installed
--> Processing Dependency: jna-examples for package: intellij-idea-9.0.1.94.399-10.fc13.i686
--> Finished Dependency Resolution
Error: Package: intellij-idea-9.0.1.94.399-10.fc13.i686 (@fedora)
           Requires: jna-examples
           Removing: jna-examples-3.2.4-3.fc13.i686 (@fedora)
               jna-examples = 3.2.4-3.fc13
           Obsoleted By: jna-contrib-3.2.7-5.fc13.i686 (updates)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

-----------

My workaround is excluding jna in yum.conf, to avoid the warnings above.

Comment 9 Bozhidar Batsov 2010-10-12 11:44:40 UTC
I can confirm as well that the issue still exists on Fedora 13.


Note You need to log in before you can comment on or make changes to this bug.