Bug 619061 - kexec-tools translation is not Working in Firstboot in any supported languages
kexec-tools translation is not Working in Firstboot in any supported languages
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kexec-tools (Show other bugs)
6.0
All Linux
high Severity medium
: rc
: ---
Assigned To: Cong Wang
Ankit Patel
: i18n, RHELNAK, Translation
: 552171 552176 552182 552225 559099 563003 563005 567445 (view as bug list)
Depends On:
Blocks: 576455 552158
  Show dependency treegraph
 
Reported: 2010-07-28 09:35 EDT by A S Alam
Modified: 2013-09-29 22:19 EDT (History)
13 users (show)

See Also:
Fixed In Version: kexec-tools-2_0_0-132_el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-11 09:45:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot of a localized kdump screen from firstboot (134.60 KB, image/png)
2010-07-30 02:11 EDT, Ankit Patel
no flags Details

  None (edit)
Description A S Alam 2010-07-28 09:35:28 EDT
Description of problem:
kexec-tools translation is not Working in Firstboot in any supported languages.

Version-Release number of selected component (if applicable):
firstboot-1.110.5-1.el6.x86_64
kexec-tools-2.0.0-125.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. LANG=ru_RU.UTF-8 firstboot --debug --reconfig
2. observe Kdump screen
3.
  
Actual results:
kdump window is appearing in English

Expected results:
kdump window should appear in respective locale (Russian)

Additional info:
Russian is 100% translated for kexec-tools
Comment 1 A S Alam 2010-07-28 09:37:49 EDT
*** Bug 552182 has been marked as a duplicate of this bug. ***
Comment 2 A S Alam 2010-07-28 09:38:01 EDT
*** Bug 552225 has been marked as a duplicate of this bug. ***
Comment 3 A S Alam 2010-07-28 09:38:48 EDT
*** Bug 559099 has been marked as a duplicate of this bug. ***
Comment 4 A S Alam 2010-07-28 09:39:32 EDT
*** Bug 563003 has been marked as a duplicate of this bug. ***
Comment 5 A S Alam 2010-07-28 09:39:39 EDT
*** Bug 563005 has been marked as a duplicate of this bug. ***
Comment 6 A S Alam 2010-07-28 09:40:26 EDT
*** Bug 567445 has been marked as a duplicate of this bug. ***
Comment 7 A S Alam 2010-07-28 09:41:00 EDT
*** Bug 552171 has been marked as a duplicate of this bug. ***
Comment 9 A S Alam 2010-07-28 09:41:52 EDT
*** Bug 552176 has been marked as a duplicate of this bug. ***
Comment 10 RHEL Product and Program Management 2010-07-28 09:57:49 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 11 A S Alam 2010-07-28 10:34:57 EDT
it is effecting all supported language, so requesting for Blocker
Comment 12 Cong Wang 2010-07-29 00:31:50 EDT
Is this a firstboot problem or kexec-tools problem? Note that firstboot_kdump.py is provided by kexec-tools.
Comment 13 Cong Wang 2010-07-29 01:34:04 EDT
I think this is due to that firstboot use /usr/share/locale/$LANG/LC_MESSAGES/firstboot.mo, while kexec-tools install the po/mo file as /usr/share/locale/$LANG/LC_MESSAGES/kexec-tools.mo.
Comment 14 Ankit Patel 2010-07-29 02:02:46 EDT
(In reply to comment #13)
> I think this is due to that firstboot use
> /usr/share/locale/$LANG/LC_MESSAGES/firstboot.mo, while kexec-tools install the
> po/mo file as /usr/share/locale/$LANG/LC_MESSAGES/kexec-tools.mo.    

I guess not. Because firstboot calls s-c-date, s-c-user, etc tools as well, where translations are picked up from mo files of those individual apps. So, in the case of kdump screen it should use kexec-tools.mo only, rather than looking firstboot.mo.

Anyways, someone might want to closely look at this bug.

Thanks!
Ankit
Comment 15 Cong Wang 2010-07-29 02:17:26 EDT
(In reply to comment #14)
> (In reply to comment #13)
> > I think this is due to that firstboot use
> > /usr/share/locale/$LANG/LC_MESSAGES/firstboot.mo, while kexec-tools install the
> > po/mo file as /usr/share/locale/$LANG/LC_MESSAGES/kexec-tools.mo.    
> 
> I guess not. Because firstboot calls s-c-date, s-c-user, etc tools as well,
> where translations are picked up from mo files of those individual apps. So, in
> the case of kdump screen it should use kexec-tools.mo only, rather than looking
> firstboot.mo.
> 

I don't know why firstboot calls s-c-XXX here, for kexec-tools, s-c-kdump is a different package which should not be called by firstboot. And it is kexec-tools which provides firstboot_kdump.py and kexec-tools.mo, not s-c-kdump.

And strace shows firstboot even doesn't look for kexec-tools.mo.
Comment 16 Martin Gracik 2010-07-29 06:09:28 EDT
Hi,

it is looking for firstboot.mo because in /usr/share/firstboot/modules/firstboot_kdump.py there is _ = lambda x: gettext.ldgettext("firstboot", x) instead of the proper ...ldgettext("kexec-tools", x).
So change that line and it will work.
Comment 17 Ankit Patel 2010-07-29 06:20:54 EDT
(In reply to comment #16)
> Hi,
> 
> it is looking for firstboot.mo because in
> /usr/share/firstboot/modules/firstboot_kdump.py there is _ = lambda x:
> gettext.ldgettext("firstboot", x) instead of the proper
> ...ldgettext("kexec-tools", x).
> So change that line and it will work.    

Cool, let's know once you fix this and make a new build.

Thanks!
Ankit
Comment 18 Cong Wang 2010-07-29 06:59:13 EDT
Thanks much, Martin! That works!
Comment 19 Ankit Patel 2010-07-30 02:11:39 EDT
Created attachment 435472 [details]
screenshot of a localized kdump screen from firstboot

Attached screenshot is taken for Gujarati.

It's verified with kexec-tools-2.0.0-132.el6.x86_64. WORKING. FIXED.

Thanks to all who worked hard on this to fix it.
Comment 20 releng-rhel@redhat.com 2010-11-11 09:45:15 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.