Bug 61912 - skipjack ships with Pan 0.9.7, which is ~20 releases old!
skipjack ships with Pan 0.9.7, which is ~20 releases old!
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: pan (Show other bugs)
skipjack-beta1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jens Petersen
:
: 61960 (view as bug list)
Depends On:
Blocks: 61901
  Show dependency treegraph
 
Reported: 2002-03-25 17:20 EST by Charles Kerr
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-06 10:57:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rebuilding 0.11.2 on 7.3 (47.70 KB, text/plain)
2002-04-04 04:12 EST, Bill Huang
no flags Details

  None (edit)
Description Charles Kerr 2002-03-25 17:20:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:0.9.9+) Gecko/20020315

Description of problem:
It looks like the version of Pan shipping with slipjack
is still 0.9.7, which is almost a year old.

I'd like to request (plead?) that this be upgraded to
Pan 0.11.2, which much more stable than 0.9.7.  IMO 0.11.2
is the best choice for bundling with a stable, non-beta distro.

I'm constantly getting bug reports against 0.9.7 users
from RH.  0.11.2 has been out for about two months now
and has no major/repeatable bug reports.  Make my life
easier and upgrade away from 0.9.7 in the next RH release. :)

Tarballs and RH7.2 RPMs can be found at http://pan.rebelbase.com/download/0.11.2/

cheers,
Charles

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. start pan
2. go to Help|About
3. look at the version number
	

Actual Results:  0.9.7 was displayed.

Expected Results:  0.11.2 should have been displayed. ;)

Additional info:
Comment 1 Charles Kerr 2002-03-26 12:20:31 EST
Bill:  Excuse me for being presumptuous in marking this
bug as assigned to you, but havill got the mail from bugzilla
when I filed this bug, and he says you're the person I
should be talking to you, so I wanted to make sure you were
in the loop.
Comment 2 Bill Nottingham 2002-03-26 14:53:29 EST
*** Bug 61960 has been marked as a duplicate of this bug. ***
Comment 3 Jim Henderson 2002-04-03 21:57:58 EST
Agree with Charles here, a more current version of pan is warranted because there have been many good feature enhancements and bugfixes, as well as 
performance improvements.  0.9.7 is quite out of date.
Comment 4 Need Real Name 2002-04-04 00:20:28 EST
Please update Pan from the RAWHIDE destribution, to at least version 0.11.2, 
since it is impossible to post to newsgroups with the shipped version, without 
pan crashing..

Fabian Olesen
Comment 5 Bill Huang 2002-04-04 00:26:35 EST
Yes.I started to maintianenc 2 week ago.

Now 0.11.1 has been rebuilt for 7.3 in rawhide.

I met some troubles when rebuilt 0.11.2 for 7.3.
Comment 6 Charles Kerr 2002-04-04 02:35:30 EST
What problem did you encounter when building 0.11.2 for 7.3?
I'll try to fix it for you.
Should I try to build on Skipjack?
Comment 7 Bill Huang 2002-04-04 04:12:25 EST
Created attachment 52165 [details]
rebuilding 0.11.2 on 7.3
Comment 8 Bill Huang 2002-04-04 04:14:21 EST
The rebuilding log is attached.
It is appreciated if you can help to rebuild 0.11.2 on 7.3.
Comment 9 Charles Kerr 2002-04-05 18:19:06 EST
I just finished downloading the last skipjack last
night, and now there's another release.. :)

I'll redownload & try to get Pan building on
skipjack beta 2 this weekend.
Comment 10 Bill Huang 2002-04-05 18:38:44 EST
Thanks very much,your help is greatly appreciated.:-)
Please tell me how you resolve the problem.
Comment 11 Need Real Name 2002-04-05 19:14:39 EST
Bill,

I'm one of the Pan developers and I've done a bit of work on the spec file. I
think I know what's going on here.

Basically, I suspect you are now building with the spec file contained in Pan's
tarball, whereas before RedHat used their own spec file.  Perhaps you can find
out which spec file was used for the 0.11.1 in RawHide ?

I think you can get Pan's spec file to work by removing the following line:

    cp /usr/share/gettext/po/Makefile.in.in po

This line is there for historic reasons: it made sure that, when building the
rpm, we got the version of Makefile.in.in that came with gettext 0.10.35 (or
later). We copied it in, just in case the tarball packager didn't have that
version yet. We needed that version, because it supports DESTDIR, which we need
to copy the translation files during install. I never really liked that
solution, and now I remember why. :-)

The problem you're seeing is that Skipjack uses gettext 0.11. The Makefile.in.in
in that version seems to be different, in that it doesn't directly define the
variable 'top_builddir' (it seems to get pulled in from po/Makevars, but I
haven't had time to investigate that).  

If you remove that copy from the spec, you can just build with the included
Makefile.in.in, and the build should proceed fine.  Alternatively, you can
switch to RH's own spec file for Pan.

Hope this helps,
Christophe
Comment 12 Bill Huang 2002-04-06 10:57:24 EST
Christophe:Thanks for your advice.Now I switch to RH's spec file for pan and the
building is passed.

Note You need to log in before you can comment on or make changes to this bug.