Bug 619145 - SELinux is preventing /bin/dbus-daemon "sendto" access on /dev/log.
SELinux is preventing /bin/dbus-daemon "sendto" access on /dev/log.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
14
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:ef7fc7f2c17...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-28 13:03 EDT by Eric Blake
Modified: 2010-07-28 13:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-28 13:09:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Blake 2010-07-28 13:03:22 EDT
Summary:

SELinux is preventing /bin/dbus-daemon "sendto" access on /dev/log.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by dbus-daemon. It is not expected that this
access is required by dbus-daemon and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:system_r:abrt_helper_t:s0-s0:c0.c1023
Target Context                system_u:system_r:kernel_t:s0
Target Objects                /dev/log [ unix_dgram_socket ]
Source                        pulseaudio
Source Path                   /usr/bin/pulseaudio
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           dbus-1.3.2-0.0.885483.fc14
Target RPM Packages           
Policy RPM                    selinux-policy-3.8.8-3.fc14
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.35-0.56.rc6.git1.fc14.i686.PAE #1
                              SMP Sat Jul 24 00:49:51 UTC 2010 i686 i686
Alert Count                   2
First Seen                    Wed 28 Jul 2010 10:31:23 AM MDT
Last Seen                     Wed 28 Jul 2010 10:31:24 AM MDT
Local ID                      dbc1f090-a4f6-49e3-8cfe-9c27987089ed
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1280334684.939:822): avc:  denied  { sendto } for  pid=2037 comm="dbus-daemon" path="/dev/log" scontext=unconfined_u:system_r:abrt_helper_t:s0-s0:c0.c1023 tcontext=system_u:system_r:kernel_t:s0 tclass=unix_dgram_socket

node=(removed) type=SYSCALL msg=audit(1280334684.939:822): arch=40000003 syscall=102 success=yes exit=69 a0=9 a1=b770fd90 a2=2adff4 a3=0 items=0 ppid=1 pid=2037 auid=14986 uid=14986 gid=14986 euid=14986 suid=14986 fsuid=14986 egid=14986 sgid=14986 fsgid=14986 tty=(none) ses=1 comm="dbus-daemon" exe="/bin/dbus-daemon" subj=unconfined_u:system_r:abrt_helper_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,pulseaudio,abrt_helper_t,kernel_t,unix_dgram_socket,sendto
audit2allow suggests:

#============= abrt_helper_t ==============
allow abrt_helper_t kernel_t:unix_dgram_socket sendto;
Comment 1 Daniel Walsh 2010-07-28 13:09:42 EDT
This looks like you have /bin/upstart mislabeled.

yum -y update 

To get to the latest selinux policy

selinux-policy-3.8.8-8.fc14

Note You need to log in before you can comment on or make changes to this bug.