Bug 619193 - chromium-bsu crashes after resolution change
chromium-bsu crashes after resolution change
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: chromium-bsu (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-28 16:10 EDT by Mateusz Kozyra
Modified: 2010-08-13 17:22 EDT (History)
1 user (show)

See Also:
Fixed In Version: chromium-bsu-0.9.14.1-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-13 17:22:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mateusz Kozyra 2010-07-28 16:10:26 EDT
Description of problem:
chromium-bsu crashes after resolution change or toggle fullscreen. 

Version-Release number of selected component (if applicable):
0.9.14-6.fc13

How reproducible:
run chromium-bsu and try toggling fullscreen or change resolution

Steps to Reproduce:
1. install chromium-bsu package from fedora repository
2. run from console by typing chromium-bsu
3. try change resolution or toggle fullscreen
4. game will crash with output to console
  
Actual results:
Game crashes with following output:
error loading font: GLC: couldn't set context
AL lib: ALc.c:1879: exit(): closing 1 Device
AL lib: ALc.c:1808: alcCloseDevice(): destroying 1 Context(s)
AL lib: ALc.c:1420: alcDestroyContext(): deleting 15 Source(s)
AL lib: ALc.c:1818: alcCloseDevice(): deleting 9 Buffer(s)

Expected results:
Add gothic-uralic font to repository and add it to dependencies of package chromium-bsu

Additional info:

while changing video options game searches for gothic-uralic font and it can't find it in system, so goes to crash. Font is not present in fedora repositories, but it's licence is GPL v2 so possibly it can be added to repos. Font, license and more info can be found at http://peoples.org.ru/eng_uralic.html
Comment 1 Hans de Goede 2010-08-04 09:46:24 EDT
Thanks for the bug report. The problem is not related to the missing font, othewrwise the game would not start up at all, but rather is a code issue. I'm currently preparing an update fixing this.
Comment 2 Fedora Update System 2010-08-04 09:47:38 EDT
chromium-bsu-0.9.14.1-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/chromium-bsu-0.9.14.1-1.fc13
Comment 3 Fedora Update System 2010-08-05 19:34:03 EDT
chromium-bsu-0.9.14.1-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update chromium-bsu'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/chromium-bsu-0.9.14.1-1.fc13
Comment 4 Fedora Update System 2010-08-13 17:22:02 EDT
chromium-bsu-0.9.14.1-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.