Bug 619195 - usrp-devel missing db_base.h, which is in gnuradio-devel
Summary: usrp-devel missing db_base.h, which is in gnuradio-devel
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnuradio (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Jaroslav Škarvada
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 516352
TreeView+ depends on / blocked
 
Reported: 2010-07-28 20:20 UTC by Alon Levy
Modified: 2014-08-04 22:08 UTC (History)
4 users (show)

Fixed In Version: gnuradio-3.4.0-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-28 16:54:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alon Levy 2010-07-28 20:20:57 UTC
Description of problem:
cannot build packages with usrp.h since it depends on a missing file, namely
db_base.h (in /usr/include/db_base.h), which is included in gnuradio-devel, which is not a requirement of usrp-devel (nor should it be).

Since usrp.h includes db_base.h, and usrp.h is in usrp-devel, db_base.h should also be in usrp-devel

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install usrp-devel
2. try to compile anything with usrp (for instance openbts)
3. 
  
Actual results:
fail on missing db_base.h included from usrp_basic.h line 42

Expected results:
compilation successful

Additional info:

Comment 1 Jaroslav Škarvada 2011-06-28 16:54:54 UTC
Merged to gnuradio as proposed in bug 516352.


Note You need to log in before you can comment on or make changes to this bug.