Bug 619214 - Guest OS installation fails with KVM on Redhat 6.0
Summary: Guest OS installation fails with KVM on Redhat 6.0
Status: CLOSED DUPLICATE of bug 616480
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Amit Shah
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 494052
TreeView+ depends on / blocked
 
Reported: 2010-07-28 21:34 UTC by sivakumar
Modified: 2013-01-09 22:57 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-05 15:06:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot with error when installting with DVD (420.32 KB, image/png)
2010-07-28 21:34 UTC, sivakumar
no flags Details
stack trace snapshot when instaling with iso image. (3.34 KB, text/plain)
2010-07-28 21:36 UTC, sivakumar
no flags Details

Description sivakumar 2010-07-28 21:34:59 UTC
Created attachment 435134 [details]
screen shot with error when installting with DVD

Description of problem:

There are two issues I am facing.

1) When I try to install the Guest OS using CDROM, I am getting "Boot Failed: Could not read from CDROM (code 0003)" error message. Attached a screen shot of the same.
2) Then I try to use iso image from hard drive and the installation hangs in the middle with the kernel stack trace. I have attached the stack trace with the bug.

Version-Release number of selected component (if applicable):
Redhat 6.0 snapshot 7 refresh.

How reproducible:
Try to install redhat 5.5 as guest os using VMM on rehdat 6.0 with KVM support.

Comment 1 sivakumar 2010-07-28 21:36:13 UTC
Created attachment 435135 [details]
stack trace snapshot when instaling with iso image.

Comment 3 RHEL Product and Program Management 2010-07-28 22:07:34 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 5 sivakumar 2010-07-29 23:39:48 UTC
I tried with snapshot8 of redhat 6.0. With this, I was able to install the guest OS using iso image option. I am getting same error with DVD option with snapshot8 as well.

Comment 6 Larry Troan 2010-07-30 12:05:42 UTC
On Thu, 2010-07-29 at 19:21 -0700, Ramkrishna Vepa wrote:
> Hi Larry,
> 
> This seems to be a regression as it was working in the previous snapshots we
> tested.
> 
> Ram

Comment 8 Amit Shah 2010-08-05 08:26:17 UTC
Are you installing using virt-install? There was a bug which has been fixed recently that allows using the host's cdrom device for guest installs.

Bug 616480 is the bug with virt-inst; so maybe this is a dup.

Comment 9 Dor Laor 2010-08-05 15:06:23 UTC
I'll close it as a duplicate of 616480.
If it is not the case, I suspect this is something todo with picking the right boot partition. In that case please provide the rpms versions for seabios, kernel, qemu-kvm and libvirt.

*** This bug has been marked as a duplicate of bug 616480 ***

Comment 10 sivakumar 2010-08-05 16:25:15 UTC
Is the fix discussed in bug 616480 is available in Redhat 6.0 snapshot 9?

Comment 11 Ronald Pacheco 2010-08-05 16:28:35 UTC
Yes.


Note You need to log in before you can comment on or make changes to this bug.