Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.

Bug 619214

Summary: Guest OS installation fails with KVM on Redhat 6.0
Product: Red Hat Enterprise Linux 6 Reporter: sivakumar <sivakumar.subramani>
Component: kernelAssignee: Amit Shah <amit.shah>
Status: CLOSED DUPLICATE QA Contact: Red Hat Kernel QE team <kernel-qe>
Severity: high Docs Contact:
Priority: high    
Version: 6.0CC: amit.shah, ltroan, rpacheco, tburke
Target Milestone: rc   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-08-05 15:06:23 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 494052    
Attachments:
Description Flags
screen shot with error when installting with DVD
none
stack trace snapshot when instaling with iso image. none

Description sivakumar 2010-07-28 21:34:59 UTC
Created attachment 435134 [details]
screen shot with error when installting with DVD

Description of problem:

There are two issues I am facing.

1) When I try to install the Guest OS using CDROM, I am getting "Boot Failed: Could not read from CDROM (code 0003)" error message. Attached a screen shot of the same.
2) Then I try to use iso image from hard drive and the installation hangs in the middle with the kernel stack trace. I have attached the stack trace with the bug.

Version-Release number of selected component (if applicable):
Redhat 6.0 snapshot 7 refresh.

How reproducible:
Try to install redhat 5.5 as guest os using VMM on rehdat 6.0 with KVM support.

Comment 1 sivakumar 2010-07-28 21:36:13 UTC
Created attachment 435135 [details]
stack trace snapshot when instaling with iso image.

Comment 3 RHEL Program Management 2010-07-28 22:07:34 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 5 sivakumar 2010-07-29 23:39:48 UTC
I tried with snapshot8 of redhat 6.0. With this, I was able to install the guest OS using iso image option. I am getting same error with DVD option with snapshot8 as well.

Comment 6 Larry Troan 2010-07-30 12:05:42 UTC
On Thu, 2010-07-29 at 19:21 -0700, Ramkrishna Vepa wrote:
> Hi Larry,
> 
> This seems to be a regression as it was working in the previous snapshots we
> tested.
> 
> Ram

Comment 8 Amit Shah 2010-08-05 08:26:17 UTC
Are you installing using virt-install? There was a bug which has been fixed recently that allows using the host's cdrom device for guest installs.

Bug 616480 is the bug with virt-inst; so maybe this is a dup.

Comment 9 Dor Laor 2010-08-05 15:06:23 UTC
I'll close it as a duplicate of 616480.
If it is not the case, I suspect this is something todo with picking the right boot partition. In that case please provide the rpms versions for seabios, kernel, qemu-kvm and libvirt.

*** This bug has been marked as a duplicate of bug 616480 ***

Comment 10 sivakumar 2010-08-05 16:25:15 UTC
Is the fix discussed in bug 616480 is available in Redhat 6.0 snapshot 9?

Comment 11 Ronald Pacheco 2010-08-05 16:28:35 UTC
Yes.