Bug 619232 - [abrt] crash in gbirthday-0.6.5-1.fc13: databases.py:438:parse:AttributeError: 'NoneType' object has no attribute 'close'
Summary: [abrt] crash in gbirthday-0.6.5-1.fc13: databases.py:438:parse:AttributeError...
Status: CLOSED DUPLICATE of bug 601372
Alias: None
Product: Fedora
Classification: Fedora
Component: gbirthday   
(Show other bugs)
Version: 13
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Thomas Spura
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:adf901dd
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-29 00:23 UTC by mdmpsyd@gmail.com
Modified: 2010-07-29 08:29 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-29 08:29:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (760 bytes, text/plain)
2010-07-29 00:23 UTC, mdmpsyd@gmail.com
no flags Details

Description mdmpsyd@gmail.com 2010-07-29 00:23:41 UTC
abrt 1.1.1 detected a crash.

architecture: i686
cmdline: /usr/bin/python /usr/bin/gbirthday
component: gbirthday
executable: /usr/bin/gbirthday
kernel: 2.6.33.6-147.fc13.i686.PAE
package: gbirthday-0.6.5-1.fc13
reason: databases.py:438:parse:AttributeError: 'NoneType' object has no attribute 'close'
release: Fedora release 13 (Goddard)

backtrace
-----
databases.py:438:parse:AttributeError: 'NoneType' object has no attribute 'close'

Traceback (most recent call last):
  File "/usr/bin/gbirthday", line 4, in <module>
    main()
  File "/usr/lib/python2.6/site-packages/gbirthday/__init__.py", line 185, in main
    addressbook.reload()
  File "/usr/lib/python2.6/site-packages/gbirthday/addressbook.py", line 109, in reload
    database.parse()
  File "/usr/lib/python2.6/site-packages/gbirthday/databases.py", line 438, in parse
    self.conn.close()
AttributeError: 'NoneType' object has no attribute 'close'

Local variables in innermost frame:
msg: AttributeError("'NoneType' object has no attribute 'execute'",)
qry: 'SELECT name, date FROM person'
self: <gbirthday.databases.MySQL instance at 0x939b4ac>

Comment 1 mdmpsyd@gmail.com 2010-07-29 00:23:43 UTC
Created attachment 435167 [details]
File: backtrace

Comment 2 Thomas Spura 2010-07-29 08:29:46 UTC
Thanks for the bug report.

Unfortunately, I can't fix this by myself, because I have no clue about mysql.

The other author of gbirthday is busy atm, so it could take a while, till this is fixed...

Sorry.

*** This bug has been marked as a duplicate of bug 601372 ***


Note You need to log in before you can comment on or make changes to this bug.