Bug 619240 - JBoss AS6 M4 cannot be managed by RHQ due to profile service mgmt API classes having been moved to different jars
Summary: JBoss AS6 M4 cannot be managed by RHQ due to profile service mgmt API classes...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: RHQ Project
Classification: Other
Component: Plugins   
(Show other bugs)
Version: 3.0.0
Hardware: All
OS: All
urgent
high vote
Target Milestone: ---
: ---
Assignee: Charles Crouch
QA Contact: Mike Foley
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-29 01:05 UTC by Ian Springer
Modified: 2015-02-01 23:26 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-03 16:47:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (147.52 KB, image/png)
2011-06-27 07:04 UTC, Sunil Kondkar
no flags Details

Description Ian Springer 2010-07-29 01:05:08 UTC
For all the details on the changes to JBAS that broke things, see https://jira.jboss.org/browse/JBAS-8263.

Comment 1 Ian Springer 2010-07-29 01:54:49 UTC
I believe the fix for this is simply adding common/lib/jboss-as-profileservice.jar and lib/jboss-profileservice-spi.jar to the list of client jars in org.rhq.plugins.jbossas5.ApplicationServerDiscoveryComponent. However, because the PC's plugin connection classloader infrastructure blows up when jars that don't exist are added to the connection classloader, we need to either only add these two jars to the list of client jars if they exist or only add them if the discovered AS instance's version is 6.0 M4.

In my testing, adding these two jars does allow the as5 plugin to successfully connect to an AS6 M4 instance (i.e. the resource component starts successfully).

Comment 2 Ian Springer 2010-07-29 21:11:13 UTC
Note, it's not the PC's plugin connection classloader infrastructure that blows up if one of the client jars doesn't exist - it's the as5 plugin itself. We should probably change it so it just logs a warning rather than blowing up, since, as this issue demonstrates, the exact set of required jars varies from version to version.

Comment 3 Charles Crouch 2010-07-30 02:57:19 UTC
Needs to get this into Master, not the 2.4 release branch

Comment 4 Ian Springer 2010-09-17 21:53:29 UTC
This has been fixed in master via commit 727c897. We can now discover and manage AS6 M4. 

Once AS6 CR1 is released in November, we should test again and make sure everything still works.

Comment 5 Sunil Kondkar 2011-06-27 07:01:59 UTC
Verified on build#158 (Version: 4.1.0-SNAPSHOT Build Number: c1539ab)

Downloaded jboss-6.0.0.20101110-CR1. Started the server and discovered it successfully. It is shown green. Please refer the attached screenshot.

Verified that monitoring, importing a test script works for the resource.

Marking as verified.

Comment 6 Sunil Kondkar 2011-06-27 07:04:34 UTC
Created attachment 510028 [details]
Screenshot


Note You need to log in before you can comment on or make changes to this bug.