Bug 619242 - Incorrect logic when querying for existence of an exchange while parsing an address string.
Summary: Incorrect logic when querying for existence of an exchange while parsing an a...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-java   
(Show other bugs)
Version: Development
Hardware: All
OS: Linux
low
medium
Target Milestone: 1.3
: ---
Assignee: Rajith Attapattu
QA Contact: MRG Quality Engineering
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-29 01:51 UTC by Rajith Attapattu
Modified: 2013-02-25 10:50 UTC (History)
1 user (show)

Fixed In Version: 0.10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-25 10:50:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache JIRA QPID-2774 None None None Never

Description Rajith Attapattu 2010-07-29 01:51:40 UTC
Description of problem:
Consider the following address string,
"HELLO/world; {create: never, node: { type: topic }}", where HELLO is a pre existing exchange of type 'direct'.

Since the type of the exchange is not specified, the Java client defaults to 'topic' right at the beginning and incorrectly compares the exchange type when querying for the exchange.
The default exchange type should only be specified if an exchange needs to be created and the type is missing.

How reproducible:
Always

Steps to Reproduce:
1. Create an exchange called HELLO with type 'direct'.
2. Pass the following to the Java Drain/Spout example
   "HELLO/world; {create: never, node: { type: topic }}"
3. Observe that the JMS client complains that the exchange is not found.
  
Actual results:
The JMS client throws an exception saying the exchange is not found.

Expected results:
The JMS client should be able to verify the exchange successfully.

Comment 1 Rajith Attapattu 2010-07-29 13:43:26 UTC
This is fixed in upstream (tracked via QPID-2774)
http://svn.apache.org/viewcvs?view=rev&rev=980259

Git commit URL
http://mrg1.lab.bos.redhat.com/cgit/qpid.git/commit/?id=1a2e20b0b6ac865d5d438877696c2068ed92bba2


Note You need to log in before you can comment on or make changes to this bug.