Bug 6193 - gtk_widget_map failing with most/any window opening
Summary: gtk_widget_map failing with most/any window opening
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: linuxconf   
(Show other bugs)
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-21 18:14 UTC by web
Modified: 2015-07-13 22:58 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-22 21:21:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description web 1999-10-21 18:14:44 UTC
Running linuxconf as root in X-windows gives the following
error message during the add user process.
Error message from remadmin :
Error message from remadmin :Gtk-CRITICAL **: file
gtkwidget.c: line 1584 (gtk_widget_map): assertion
`GTK_WIDGET_VISIBLE (widget) == TRUE' failed.

This may be a configuration problem - if so please let me
know.

Comment 1 web 1999-10-28 05:03:59 UTC
This error seems to happen on "any" (haven't tried them all) opening
of a window into a specific setup item. ie when a window opens on the
right in the GUI mode.
Error message from remadmin :
Error message from remadmin :Gtk-CRITICAL **: file gtkwidget.c: line
1584 (gtk_widget_map): assertion `GTK_WIDGET_VISIBLE (widget) == TRUE'
failed.

The error repeats itself a different amount of times for each window
depending on what is being displayed.

This may be a setup problem - if so, please let me know

------- Additional Comments From   10/28/99 15:46 -------
I have had the same problem, but only with linuxconf.  I'm using the
KDE desktop, but the GNOME linuxconf comes up.  I can consistently
recreate this error when I go into the basic network options (where I
assign an IP address to my ethernet interface).
On a related note, there seems to be an issue where your display
settings can effect how often you can start a program up.  If I start
up Netscape, shut it down, and attempt to start it up again (via the
GUI) nothing happens.  When I type "netscape" at a shell prompt, I get
an error the following error:

Xlib: connection to ":0.0" refused by server
Xlib: Client is not authorized to connect to Server

Gtk-WARNING **:cannot open display: :0

I'm running RH 6.1 on a Toshiba laptop, and had previously installed
RH 6.0 on it, so I know it runs Linux.

tom@yarrish.com

Comment 2 Michael K. Johnson 1999-11-19 20:00:59 UTC
tom:
This is a warning, not an error.  The netscape bug has nothing to do
with this.  It probably has nothing to do with netscape; it sounds
like your xauthority configuration is messed up.  Please open a
separate bug report about that and include the output of
  echo $DISPLAY
  xauth list $DISPLAY
in that bug report.

To the original reporter:
This warning shouldn't cause problems, but I'll look into fixing it.

Comment 3 tom 1999-11-22 18:54:59 UTC
John,
I was just using netscape as an example, but I would get the same error with any
X-window application that I would try and run more than once.  Unfortunately, I
can't send you the output you requested.  This problem basically made RH6.1
unusable for me, so I reinstalled RH6.0.  But this actual problem would occur
right after an upgrade, so I don't know where the xauthority configuration could
have been screwed up.  I never set it up to begin with, nor have I changed it in
anyway (meaning in RH6.0 the problem is not there).
tom@yarrish.com

Comment 4 Michael K. Johnson 1999-11-22 21:21:59 UTC
Did you get that root window by doing "su -" by any chance?  If so, the
sh-utils from rawhide fixes the problem.  xauth keys were being forwarded
from users to root on "su" but not "su -".

Comment 5 openshift-github-bot 2015-07-13 22:58:00 UTC
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/17a5280ba1d32a662d91f4a57cc8bddb424e514a
Merge pull request #6196 from tiwillia/issue6193

Merged by openshift-bot


Note You need to log in before you can comment on or make changes to this bug.