Bug 619323 - SELinux is preventing /usr/bin/perl "ioctl" access on /usr/share/perl5/strict.pm.
SELinux is preventing /usr/bin/perl "ioctl" access on /usr/share/perl5/s...
Status: CLOSED DUPLICATE of bug 616594
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:0f55655f61b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-29 05:32 EDT by Peter Klöppel
Modified: 2010-07-29 13:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-29 13:10:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Klöppel 2010-07-29 05:32:10 EDT
Summary:

SELinux is preventing /usr/bin/perl "ioctl" access on
/usr/share/perl5/strict.pm.

Detailed Description:

SELinux denied access requested by lpstat. It is not expected that this access
is required by lpstat and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:system_r:munin_services_plugin_t:s0
Target Context                system_u:object_r:usr_t:s0
Target Objects                /usr/share/perl5/strict.pm [ file ]
Source                        lpstat
Source Path                   /usr/bin/perl
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           perl-5.10.1-114.fc13
Target RPM Packages           perl-5.10.1-114.fc13
Policy RPM                    selinux-policy-3.7.19-39.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.33.6-147.fc13.i686 #1 SMP Tue Jul 6
                              22:30:55 UTC 2010 i686 i686
Alert Count                   13
First Seen                    Wed 26 May 2010 03:40:23 PM CEST
Last Seen                     Wed 28 Jul 2010 12:01:06 PM CEST
Local ID                      31d5d80f-e8e6-4518-9117-83ec275482d8
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1280311266.449:21616): avc:  denied  { ioctl } for  pid=6443 comm="lpstat" path="/usr/share/perl5/strict.pm" dev=sda2 ino=10621 scontext=unconfined_u:system_r:munin_services_plugin_t:s0 tcontext=system_u:object_r:usr_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1280311266.449:21616): arch=40000003 syscall=54 success=no exit=-25 a0=4 a1=5401 a2=bf883108 a3=bf883148 items=0 ppid=6039 pid=6443 auid=500 uid=490 gid=478 euid=490 suid=490 fsuid=490 egid=478 sgid=478 fsgid=478 tty=(none) ses=1 comm="lpstat" exe="/usr/bin/perl" subj=unconfined_u:system_r:munin_services_plugin_t:s0 key=(null)



Hash String generated from  catchall,lpstat,munin_services_plugin_t,usr_t,file,ioctl
audit2allow suggests:

#============= munin_services_plugin_t ==============
allow munin_services_plugin_t usr_t:file ioctl;
Comment 1 Daniel Walsh 2010-07-29 13:10:40 EDT

*** This bug has been marked as a duplicate of bug 616594 ***

Note You need to log in before you can comment on or make changes to this bug.