This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 61934 - Installer can leave partitions in /etc/fstab unmountable
Installer can leave partitions in /etc/fstab unmountable
Status: CLOSED WORKSFORME
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
skipjack-beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks: 61590
  Show dependency treegraph
 
Reported: 2002-03-25 20:41 EST by Need Real Name
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-10 12:05:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-03-25 20:41:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020311

Description of problem:
By default, anaconda uses labels instead of device names.  During the install,
formatting partitions have device labels added to them.  However, if you choose
to not format a partition, and the partition dosen't have a label defined, it
fails to mount on bootup.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Format a partition without defining a label

2.Install redhat, choosing a mountpoint for the partition, and choose to not
format it.

3.Attempt to boot the machine
	

Actual Results:  The machine attempts to mount the partition with the matching
label, which dosen't exist.  The machine then prompts for the root password to
repair the disk.

Expected Results:  The installer should detect that the label dosen't exist and
either:

1) add the device name into /etc/fstab instead of the label

2) Add the label to the partition (not preferred since choosing to not modify a
partition should not modify the partition)

Additional info:
Comment 1 Jeremy Katz 2002-03-27 01:59:09 EST
This is actually exactly the algorithm which is used.  What did your
partitioning look like before and after the install (including what was labelled
where)?  If you tune2fs -l the partition which you didn't format, does it really
not have a label?  Was the partition that caused problems an ext2 partition?
Comment 2 Need Real Name 2002-03-28 15:58:42 EST
On first bootup, the partition had no label.  I used tune2fs -l to add the
label, and it mounted fine on the next bootup.

The problematic partition was ext3, not ext2.
Comment 3 Jeremy Katz 2002-03-31 15:07:46 EST
Hrmm... I can't reproduce this here, but will keep trying.
Comment 4 Need Real Name 2002-04-01 11:16:49 EST
I'm not sure if it would matter or not, but the partition was not a standard
named partition (not /usr /home /boot, etc.)  

The partition name was /scratch.  I doubt it would matter, but just in case :)
Comment 5 Jeremy Katz 2002-04-09 19:23:46 EDT
What sort of device was the partition in question on?
Comment 6 Need Real Name 2002-04-10 12:05:48 EDT
18 gig SCSI hard drive.  Fujitsu model MAJ3182MP
Comment 7 Jeremy Katz 2002-04-15 18:08:42 EDT
I still can't reproduce this :(  If you can reproduce this and see any useful
messages on tty3 or tty5 during the install, feel free to reopen the bug

Note You need to log in before you can comment on or make changes to this bug.