Bug 619367 - weak-modules doesn't find symvers file
weak-modules doesn't find symvers file
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: driver-update-program (Show other bugs)
6.0
All Linux
high Severity high
: rc
: ---
Assigned To: Jon Masters
CAI Qian
: RHELNAK
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-29 07:57 EDT by Martin Wilck
Modified: 2010-10-23 11:55 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-03 10:05:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Wilck 2010-07-29 07:57:24 EDT
Description of problem:
# /sbin/weak-modules --verbose --add-kernel 2.6.32-52.el6
Symvers dump file /boot/symvers-2.6.32-52.el6.gz not found

# ls -l /boot/symvers*gz
-rw-r--r--. 1 root root 161301 Jun 21 01:45 /boot/symvers-2.6.32-37.el6.x86_64.gz
-rw-r--r--. 1 root root 161201 Jul 21 18:27 /boot/symvers-2.6.32-52.el6.x86_64.gz


Version-Release number of selected component (if applicable):
module-init-tools 3.9-15.el6

How reproducible:
always


Steps to Reproduce:
1. install kmod
2. update kernel, or install new one
3. run weak-modules --verbose --add-kernel  

Actual results:
see above

Expected results:
weak-modules links are created, or the weak-modules says that the kernels are incompatible.

Additional info:
I am attaching a script session demonstrating the problem.
This is severe because it would prevent RHDUP from functioning properly.
Comment 1 Martin Wilck 2010-07-29 07:59:43 EDT
opened issued tracker 1201243 for this bug.
Comment 3 RHEL Product and Program Management 2010-07-29 08:27:45 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 4 Jon Masters 2010-07-29 19:04:17 EDT
Martin, are you invoking weak-modules directly? It looks like you're calling it with the following value for the uname-r:

2.6.32-52.el6

Actually, in RHEL6, it should always include the architecture:

2.6.32-52.el6.x86_64

For example. Can you confirm, by looking at rpm -q --scripts kernel that your kernel is calling the correct script options? If you are doing this manually, please let me know why you need to call it without the full uname value.

Jon.
Comment 6 Martin Wilck 2010-07-30 03:21:05 EDT
My bad, I'm sorry. User error :-/

I had been wondering why no weak-modules links had been created, and in order to find out, called weak-modules by hand - wrongly. I apologize for the noise.
Comment 8 Ronald Pacheco 2010-08-03 10:05:28 EDT
Per comment #6, closing as not a bug.

Note You need to log in before you can comment on or make changes to this bug.