Bug 619382 - DUP does not enforce kernel compatibility with installed kmods
Summary: DUP does not enforce kernel compatibility with installed kmods
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: driver-update-program   
(Show other bugs)
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Jon Masters
QA Contact: Qian Cai
URL:
Whiteboard:
Keywords: RHELNAK
Depends On:
Blocks: 561978 580566 593390
TreeView+ depends on / blocked
 
Reported: 2010-07-29 12:40 UTC by Martin Wilck
Modified: 2018-11-14 18:50 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-18 07:34:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
script session demonstrating the problem (5.29 KB, text/plain)
2010-07-29 12:40 UTC, Martin Wilck
no flags Details

Description Martin Wilck 2010-07-29 12:40:16 UTC
Created attachment 435266 [details]
script session demonstrating the problem

Description of problem:
When a kmod is installed and an incompatible kernel is to be installed, rpm dependency checking does not cause an error or warning message (rpm -iv or yum install)

An error is only generated if the kernel is updated (rpm -Uv or yum update).


Version-Release number of selected component (if applicable):
module-init-tools 3.9-15.el6


How reproducible:
always


Steps to Reproduce:
1. install RHEL6 beta2 (2.6.32-37.el6)
2. install kmod
3. install new, incompatible kernel (e.g. snapshot8: 2.6.32-52.el6) with rpm -i
  
Actual results:
succeeds

Expected results:
error or warning message.

Additional info:
This may lead to a situation where the customer can't boot the default kernel because of a missing kmod. In RHEL5, the "yum-kmod" plugin with the "installforallkernels" option fulfilled this requirement, but yum-kmod is no longer available.

I am attaching a script session demonstrating what I mean.

Comment 2 RHEL Product and Program Management 2010-07-29 13:07:38 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 3 Jon Masters 2010-07-29 23:11:24 UTC
The RHEL6 kernels prior to GA release of RHEL6.0 may introduce such "incompatibilities" because we do not offer a kABI guarantee until the official release of RHEL6.0. The situation described in this bug should not arise in production, however I am willing to consider adding logic to catch this into the optional yum plugin we have created for RHEL6.0. I have raised this for internal discussion on the matter for 6.0 or 6.1 consideration accordingly.

Jon.

Comment 8 Jon Masters 2010-11-18 07:34:29 UTC
The situation described in this bug should not arise in production. We've discussed the matter internally and because this is unlikely to occur, we've determined that we'd rather use the resources required on other projects.


Note You need to log in before you can comment on or make changes to this bug.